Что такое pptp соединение на роутере
Перейти к содержимому

Что такое pptp соединение на роутере

  • автор:

VPN-протоколы: PPTP

Узнайте больше о плюсах и минусах использования PPTP.

Гарантия возврата денег 30 дней

Протокол PPTP.

Что такое PPTP?

PPTP (Point-to-Point Tunneling Protocol) — это туннельный протокол типа точка-точка. Протокол PPTP, работающий на TCP-порту 1723, — это один из старейших протоколов VPN, который использовался еще на Windows 95 и с тех пор является стандартным для всех версий Windows. Протокол PPTP был разработан по инициативе Microsoft, чтобы инкапсулировать протокол PPP (англ. Point-to-Point Protocol — протокол «точка-точка»).

Из всех VPN-протоколов PPTP является одним из наиболее распространенных, наиболее простых в настройке и наиболее быстро работающих протоколов. По этой причине PPTP особенно часто используется в приложениях, в которых скорость имеет первостепенное значение, например, для передачи потокового аудио или видео, а также на более старых и медленных устройствах с более ограниченными процессорами.

В то же время в протоколе PPTP обнаружены серьезные уязвимости. Его базовые протоколы аутентификации, обычно MS-CHAP-v1/v2, совершенно ненадежны и с момента его появления неоднократно взламывались при проведении анализа безопасности.

Поэтому PPTP НЕ рекомендуется, за исключением случаев, где безопасность абсолютно несущественна. В приложениях ExpressVPN этот протокол не поддерживается.

  • Быстрый
  • Поддерживается на более старых устройствах
  • Наименее безопасный

Текстовые облачка с различными VPN-протоколами.

Другие VPN-протоколы

Помимо стандартного набора протоколов ExpressVPN предлагает свой собственный протокол Lightway, который превосходит их все по скорости, надежности и безопасности. Попробуйте сами, чтобы убедиться. Узнайте больше о Lightway.

Если вы все еще не уверены, какой протокол VPN выбрать, позвольте приложению ExpressVPN автоматически выбрать лучший протокол для вашей сети.

Узнайте больше об использовании VPN

Безопасное подключение ноутбука к Интернету.

Что такое VPN?

Узнайте, как VPN защищает ваш интернет-трафик от слежки

Растение за своим ноутбуком использует ExpressVPN.

Приватный веб-серфинг

Измените свой IP-адрес и виртуальное местоположение

Ноутбук с изображением спидометра на экране.

Тест скорости

Проверьте, как быстро работают наши VPN-серверы, и выберите лучший

RussianProxy.ru

PPTP (англ. Point-to-point tunneling protocol) — туннельный протокол типа точка-точка, позволяющий компьютеру устанавливать защищённое соединение с сервером за счёт создания специального туннеля в стандартной, незащищённой, сети. PPTP помещает (инкапсулирует) кадры PPP в IP-пакеты для передачи по глобальной IP-сети, например Интернет. PPTP может также использоваться для организации туннеля между двумя локальными сетями. РРТР использует дополнительное TCP-соединение для обслуживания туннеля.

Спецификация

Спецификация протокола была опубликована как «информационный» RFC 2637 в 1999 году. Она не была ратифицирована IETF. Протокол считается менее безопасным, чем другие VPN-протоколы, например, IPSec. PPTP работает, устанавливая обычную PPP сессию с противоположной стороной с помощью протокола Generic Routing Encapsulation. Второе соединение на TCP-порте 1723 используется для инициации и управления GRE-соединением. PPTP сложно перенаправлять за сетевой экран, так как он требует одновременного установления двух сетевых сессий.

PPTP-трафик может быть зашифрован с помощью MPPE. Для аутентификации клиентов могут использоваться различные механизмы, наиболее безопасные из них — MSCHAP-v2 и EAP-TLS.

Реализация PPTP

Cisco первой реализовала PPTP и позже лицензировала эту технологию корпорации Microsoft.

PPTP удалось добиться популярности благодаря тому что это первый VPN протокол, поддерживаемый корпорацией Microsoft. Все версии Microsoft Windows, начиная с Windows 95 OSR2, включают в свой состав PPTP-клиент, однако существует ограничение на два одновременных исходящих соединения. А сервис удалённого доступа для Microsoft Windows включает в себя PPTP сервер.

До недавнего времени в Linux-дистрибутивах отсутствовала полная поддержка PPTP из-за опасения патентных претензий по поводу протокола MPPE. Впервые полная поддержка MPPE появилась в Linux 2.6.13. Официально поддержка PPTP была начата с версии ядра Linux 2.6.14.

Операционная система FreeBSD поддерживает PPTP протокол, используя в качестве сервера PPTP порт mpd (/usr/ports/net/mpd), используя подсистему netgraph. В качестве клиента PPTP в системе FreeBSD может выступать либо порт pptpclient (/usr/ports/net/pptpclient), либо порт mpd, работающий в режиме клиента.

Mac OS X поставляется со встроенным PPTP клиентом. Cisco и Efficient Networks продают реализации PPTP клиента для более старых версий Mac OS. КПК Palm, имеющие поддержку Wi-Fi, поставляются с PPTP клиентом Mergic.

Microsoft Windows Mobile 2003 и более новые также поддерживают PPTP.

Пожалуйста, обратите внимание, что PPTP VPN сервис использует для своей работы порт TCP 1721/TCP и протокол IP GRE (номер 47). Такие пакеты должны проходить через Ваш Firewall/NAT (и соответственно, Firewall/NAT Вашего провайдера), а если по дороге до нашего сервера есть NAT, то он должен корректно обрабатывать VPN соединение в целом (как правило, это осуществляется с помощью модуля PPTP NAT helper).

Наши сервера поддерживают PPTP VPN c MPPE (Microsoft Point-to-Point Encryption) шифрованием и MPPC сжатием.

© 1996-2023 RussianProxy.ru — Outline ShadowSocks / PPTP / L2TP / OpenVPN TCP / OpenVPN UDP VPN сервис, русский выделенный IP, безлимитные тарифы.

Техническая поддержка

PPTP в роутере RTU: Часть 2 — Примеры настройки режима «PPTP Клиент» для различных устройств и систем при подключении к роутеру RTU в режиме «PPTP Сервер» Печать

Изменено: Пт, 14 Авг, 2020 на 3:22 PM

В роутерах серии RTU есть возможность использования защищенного соединения через частные виртуальные сети (VPN).

Разновидностей различных видов VPN-соединений довольно большое множество, но в данной статье будет рассматриваться настройка VPN-соединения протокола PPTP.

Часть конфигурирования может производиться с помощью консоли роутера, поэтому необходимо понимать, что для реализации данного метода подключения нужно обладать уверенными знаниями в области операционной системы на базе Linux.

Ознакомиться с тем, что же такое PPTP и для чего он необходим, можно в статье PPTP.

Данный материал является примером реализации туннельного протокола PPTP в разных вариантах исполнения и не является полноценным руководством.

Более детальные настройки и нюансы данного VPN-соединения можно посмотреть по ссылке: https://wiki.openwrt.org/doc/howto/vpn.server.pptpd

Роутер RTU режим «PPTP Client»

1 . Настройка с помощью WEB-интерфейса

1 .1 Создание нового интерфейса.

В разделе «Сеть» — «Интерфейсы«, нажмите на кнопку «Добавить новый интерфейс«.

Далее необходимо перейти в редактирование нового созданного интерфейса.

В основных настройках данного подключения, необходимо указать следующее:

— Протокол — PPTP

— Сервер VPN — IP-адрес удаленного сервера

— Имя пользователя PAP/CHAP — Логин для авторизации

— Пароль PAP/CHAP — Пароль для авторизации

Во вкладке «Расширенные настройки» необходимо убедиться, что у Вас установлен параметр «Использовать шлюз по умолчанию» (в определенных схемах сети, данный пункт может быть не нужен).

Во вкладке «Настройка межсетевого экрана» необходимо создать новую зону сетевого экрана.

1.2. Настройка параметров Firewall

Для того чтобы трафик проходил в локальную сеть LAN и в установленное VPN-соединение, необходимо произвести настройку параметров Firewall.

Перейдём в раздел «Сеть» -> «Межсетевой экран» и откроем для редактирования созданную ранее зону(pptp).

Необходимо задать следующие настройки:

— Входящий трафик — принимать

— Исходящий трафик — принимать

— Перенаправление — принимать

— Поставить галочку на пункте «Маскарадинг«

— Выбрать ранее созданную сеть

— Установить разрешение на перенаправление в зону назначения — LAN

— Установить разрешение на перенаправление в зону источника — LAN

После установки успешного соединения клиента PPTP с удаленным сервером, Вы можете наблюдать работу данного соединения в разделе «Сеть» — «Интерфейс«.

2 . Настройка с помощью консоли

2.1 Создание нового интерфейса.

Добавляем интерфейс PPTP в файле конфигурации nano /etc/config/network :

config interface ‘pptp’
option proto ‘pptp’
option server ‘172.26.19.18’
option username ‘teleofis’
option password ‘teleofis’
option metric ‘0’

2.2. Настройка параметров Firewall.

Для того чтобы трафик проходил в локальную сеть LAN и в установленное VPN-соединение, необходимо произвести настройку параметров Firewall.

Открываем файл конфигурации nano /etc/config/firewall :

config zone
option name ‘pptp’
option input ‘ACCEPT’
option output ‘ACCEPT’
option network ‘pptp’
option forward ‘ACCEPT’
option masq ‘1’

config forwarding
option dest ‘lan’
option src ‘pptp’

config forwarding
option dest ‘pptp’
option src ‘lan’

2.3. Настройка параметров PPTP

Открываем файл конфигурации nano /etc/ppp/options.pptp :

noipdefault
noauth
nobsdcomp
nodeflate
idle 0
mppe required,no40,no56,stateless
maxfail 0

При возникновении ошибки при подключении:

EAP: unknown authentication type 26; Naking
EAP: peer reports authentication failure

В файле конфигурации необходимо добавить строчку:

После проделанных настроек, необходимо перезагрузить роутер. На этом настройка PPTP «Клиента» завершена!

Роутер GTX(MikroTik RouterOS) режим «PPTP Клиент(Client)»

В данном пункте, будет рассматриваться базовая настройка PPP-соединения, без подробных нюансов работы с программой Winbox и настройкой другого функционала операционной системы. Ознакомиться с детальными настройками роутера на операционной системе RouterOS, Вы можете на официальном ресурсе по ссылке: https://wiki.mikrotik.com/wiki/Manual:TOC

Для начала, необходимо создать новое PPP-соединение.

В разделе PPP, необходимо нажать «+» и выбрать пункт «PPTP Client«.

В появившемся диалоговом окне, необходимо указать следующие параметры:

— Connect To — IP-адрес удаленного сервера PPTP

— User — Логин для авторизации

— Password — Пароль для авторизации

— Add Default Route — добавляет маршрут «по умолчанию»

— Allow — по необходимости, в зависимости от настройки сервера указать необходимые протоколы шифрования

После успешного подключения, Вам будет выдан IP-адрес от удаленного сервера, который можно узнать перейдя в раздел IPAddresses.

ПК на Windows 10 подключение «PPTP Клиент(Client)»

Настройка VPN-подключения в режиме «Клиент» в Windows 10.

В настройках «Сеть и Интернет» необходимо перейти в раздел VPN и добавить новое VPN-подключение.

Далее необходимо задать необходимые настройки для подключения к удаленному серверу(адрес сервера, порт сервера, имя пользователя, пароль и т.д.).

После создания нового подключения, перейдите в «Свойства» данного подключения и проверьте параметры шифрования(в зависимости от настроенной конфигурации серверной части PPTP-туннеля).

После завершения всех проделанных действий, у Вас появится новое подключение, с помощью которого, Вы сможете установить VPN-соединение подключившись к удаленному серверу!

ПК на Windows 7 подключение «PPTP Клиент(Client)»

Перейдите в сетевые настройки операционной системы «Центр управления сетями и общим доступом» и далее выберите «Создание и настройка нового подключения или сети«

Из предложенного списка, необходимо выбрать «Подключение к рабочему месту«.

В появившемся окне, выбираем «Использовать моё подключение к Интернету(VPN)«.

Далее, выбираем «Отложить решение«:

В следующем окне, необходимо указать параметры подключения, такие как:

— Интернет-адрес — IP-адрес сервера

— Имя местоназначения — Имя подключения VPN

— Пользователь — Логин для авторизации

— Пароль — Пароль для авторизации

После завершения всех проделанных действий, у Вас появится новое подключение, с помощью которого, Вы сможете установить VPN-соединение подключившись к удаленному серверу!

ПК на Linux(Ubuntu) подключение «PPTP Клиент(Client)»

В данном пункте будет рассматриваться лишь базовая настройка VPN-соединения с помощью встроенной в операционную систему Linux утилиты Network Connections.

Открыв утилиту Network Connections, необходимо нажать на кнопку Add.

В появившемся диалоговом окне, необходимо выбрать протокол «Point-to-Point Tunnelling Protocol(PPTP)» и нажать Create.

Далее, необходимо указать следующие параметры:

— Gateway — IP-адрес удаленного сервера

— User name — Логин для авторизации

— Password — Пароль для авторизации

После — перейти во вкладку «Advanced«.

В данной вкладке, необходимо включить поддерживаемые удаленным сервером протоколы шифрования, а так же выбрать параметры «Use Point-to-Point encryption(MPPE)» и «Allow stateful ecryption«.

(данные параметры, сильно зависят от настроек на удаленном сервере PPTP, поэтому, возможны различные варианты в зависимости от ситуации)

На этом настройка завершена и Ваш PPTP клиент готов к работе!

Была ли эта статья полезной? Да Нет

К сожалению, мы не смогли помочь вам в разрешении проблемы. Ваш отзыв позволит нам улучшить эту статью.

Что такое pptp соединение на роутере

  • 21.11.2020IP-телефон начального уровня Yealink SIP-T33G
  • 18.11.2020Cовременный удобный IP-телефон начального уровня Yealink SIP-T31P
  • 18.11.2020Cовременный удобный IP-телефон начального уровня Yealink SIP-T31G
  • 18.11.2020Cовременный удобный IP-телефон начального уровня Yealink SIP-T31
  • 18.11.2020IP-телефон начального уровня Yealink SIP-T30P
  • 18.11.2020IP-телефон начального уровня Yealink SIP-T30
  • 28.02.2020Конференц-телефон Panasonic KX-HDV800
  • 12.02.2020Модуль расширения Yealink EXP43
  • 12.02.2020Как правильно выбрать мобильное решение для унифицированных коммуникаций
  • 12.02.2020Микросотовая IP-DECT-система Yealink W80B
  • 31.01.2020Бизнес-телефон Yealink SIP-T43U
  • 27.01.2020Профессиональный портативный спикерфон Yealink CP700
  • 13.01.2020Компания Yealink представляет новую серию IP-телефонов T4U с расширенным набором функций
  • 09.12.2019Локальная или облачная АТС: 5 вопросов для принятия оптимального решения
  • 09.12.2019Новая прошивка V8. для станций серии Panasonic KX-NS
  • 21.11.2019Мобильные сотрудники и унифицированные коммуникации как элементы формулы успеха
  • 14.11.201911 причин, по которым IT-специалисты выбирают IP-АТС Yeastar серии S
  • 12.11.2019Как убедить босса обновить устаревшую телефонную систему
  • 15.10.20196 заблуждений о сложности обновления устаревшей телефонной системы
  • 08.10.2019Выбор IP-АТС: закрытый или открытый стандарт?

Разница между PPPoE и PPTP

Настройка сети требует минимальных знаний о протоколах соединений и их применении. Когда роутер требует указать тип соединения, ошибка в выборе может привести к отказу в подключении к сети. Разбираемся вместе, с чем едят протоколы PPPoE и PPTP.

Определение

PPPoE — сетевой протокол канального уровня передачи кадров PPP посредством подключения Ethernet.

PPTP — туннельный протокол передачи IP-пакетов с PPP кадрами.

Сравнение

Разница между PPPoE и PPTP для пользователя, прежде всего, заключается в надежности первого и способности его к аутентификации и шифрованию. PPTP создает туннельное защищенное соединение с сервером в незащищенной сети. Служебные пакеты в PPPoE занимают минимум трафика, что благотворно сказывается на скорости: при равных условиях протокол PPPoE обеспечивает обмен данными быстрее, чем PPTP. Кроме того, в PPTP за счет специфики протокола и обмена данными с сервером постоянно работают два параллельных подключения по схеме клиент-сервер: по одному передаются собственно данные, по другому — служебная информация.

PPPoE и PPTP устанавливают соединение типа точка-точка, только PPPoE устанавливает его поверх Ethernet, а PPTP — поверх IP. Применяется PPPoE для подключений, которым требуется надежная аутентификация, к примеру, подтверждение регистрации в сети провайдера посредством пары логин-пароль. PPTP применяется чаще в качестве подключения в виртуальной частной сети.

PPPoE протокол требует нахождения клиента и сервера в одной подсети, PPTP позволяет им находиться в разных. Некоторые модели роутеров не могут поднять одновременно локальную сеть и PPPoE-соединение, потому последнее заменяется на PPTP при соответствующей настройке.

PPTP, как основанный на IP протокол, очень зависим от IP-сети. Нестабильность ее или присвоение другой машине уже имеющегося IP адреса обрывают подключения, и тем чаще, чем сложнее настройки подключения. Неверные данные сетевого интерфейса не дадут подключиться, тогда как PPPoE при любых настройках свою задачу выполнит. PPTP требует приложения рук и зачастую — специфичного оборудования. PPPoE поднимается на любом оборудовании с любой операционной системой, и настройки автоматические — чаще всего неплохая реальность.

Выводы

1. PPTP работает с IP-пакетами с кадрами, PPPoE — с кадрами.
2. PPTP работает в среде IP, PPPoE — в среде Ethernet.
3. Скорость передачи данных PPPoE выше.
4. PPTP менее надежен.
5. PPPoE легче настраивается.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *