Как в скд вывести свернутые группировки
Перейти к содержимому

Как в скд вывести свернутые группировки

  • автор:

Как в скд вывести свернутые группировки

Так же, как и без СКД.
Ну и если ты думаешь, что этот вопрос никогда никем не задавался — ты сильно ошибаешься

Тип группировки — иерархия
(3) Это в коде при выводе таблицы

ВнешниеНаборыДанных = Новый Структура;

ТаблицаДанных = СоздатьТаблицуДанных();
СхемаКомпоновкиДанных = ПолучитьМакет(«Логистика»);
ВнешниеНаборыДанных.Вставить(«Логистика»,ТаблицаДанных);

ДанныеРасшифровки = Новый ДанныеРасшифровкиКомпоновкиДанных;
Настройки = КомпоновщикНастроек.ПолучитьНастройки();
КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных,Настройки, ДанныеРасшифровки);

ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки, ВнешниеНаборыДанных, ДанныеРасшифровки);
ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
ЭлементыФормы.Результат.ФиксацияСлева = 1;

ПроцессорВывода.УстановитьДокумент(ЭлементыФормы.Результат);
ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);
ЭлементыФормы.Результат.Показать();

Как свернуть все группировки при открытии отчета СКД в 1с?

Ikasteko.ru

По умолчанию, группировки в отчетах 1с раскрыты, но для удобства часто их приходится сворачивать, чтобы видеть «всю картину» отчета. Если Вас больше интересует свернутый отчет в группировках, придется добавить несколько строк кода.

Ответ

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка) СтандартнаяОбработка = Ложь; КомпоновщикМакет = Новый КомпоновщикМакетаКомпоновкиДанных; Макет = КомпоновщикМакет.Выполнить(СхемаКомпоновкиДанных, КомпоновщикНастроек.ПолучитьНастройки(), ДанныеРасшифровки); ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных; ПроцессорКомпоновки.Инициализировать(Макет, , ДанныеРасшифровки); ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент; ПроцессорВывода.УстановитьДокумент(ДокументРезультат); ПроцессорВывода.Вывести(ПроцессорКомпоновки); //ДокументРезультат.ПоказатьУровеньГруппировокСтрок(2); //Уровень 3 //ДокументРезультат.ПоказатьУровеньГруппировокСтрок(1); //Уровень 2 ДокументРезультат.ПоказатьУровеньГруппировокСтрок(0); //Уровень 1 КонецПроцедуры
Еще записи по теме
  • Как удалить все записи из регистра сведений 1с
  • Как установить шрифты?
  • Как отменить заказ на Вайлдберриз?
  • Запрос 1с: отбор по виду документа
  • Как почистить кэш браузера?
  • Как отменить заказ на мегамаркет
  • Что значит «error 404 — not found» на странице?

Как программно свернуть группировки в СКД (система компоновки данных)?

Распечатать

При формировании отчетов на СКД по умолчанию все группировки развернуты, но бывает что необходимо сразу после формирования показать отчет со свернутыми группировками!

Данный код в модуле отчета позволяет свернуть группировки до необходимого уровня (0,1,2. ):

 Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка) 

СтандартнаяОбработка = Ложь;
КомпоновщикМакет = Новый КомпоновщикМакетаКомпоновкиДанных;
Макет = КомпоновщикМакет.Выполнить(СхемаКомпоновкиДанных, КомпоновщикНастроек.Настройки, ДанныеРасшифровки);
ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновки.Инициализировать(Макет, , ДанныеРасшифровки);
ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
ПроцессорВывода.Вывести(ПроцессорКомпоновки);
//ДокументРезультат.ПоказатьУровеньГруппировокСтрок(YYYYY); //Здесь указываем УРОВЕНЬ группировки
ДокументРезультат.ПоказатьУровеньГруппировокСтрок(0);

КонецПроцедуры

Разместил: E_Migachev Версии: | 8.2 УП | 8.3 | Дата: 28.07.2014 Прочитано: 42690

Распечатать

Возможно, вас также заинтересует

Похожие FAQ

Как заполнить табличную часть формы программно? 8
Нужно по кнопке Заполнить — сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код заполнения ТЧ НаСервере П 17 правил для составления оптимального ЗАПРОСа к данным базы 1С 50
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно использовать, когда требуется получ 1С 8.x : Как убрать лидирующие нули в номере Документа (вариант2) 0
Скопировать строку с номером, с лидирующими нулями, в числовом поле (с форматом без групп, без группировки), и вернуть(скопировать) обратно в строковом поле с номером. Возвращает без нулей. Google maps : вывод точек на карту и режим панорамы 9
В отличие от яндекс карт в GMaps можно использовать панорамы — за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С возможностью просмотра панора Выборка из результата запроса всех вошедших в него значений группировок 4
При обходе результата запроса нередко возникает необходимость получения всех значений группировок внутри какой-либо другой группировки. Такая возможность может понадобиться, например, при выводе кросс отчета. Для обеспечения такой возможности в объек Посмотреть все результаты поиска похожих

Как свернуть группировки отчета в СКД программно в 1С

При формировании отчетов в СКД по умолчанию все группировки развернуты, но бывает что необходимо сразу после формирования показать отчет со свернутыми группировками в 1С.

Сворачиваем группировки до необходимого уровня (0,1,2 и т.д.) в 1С:

Процедура ПриКомпоновкеРезультата ( ДокументРезультат , ДанныеРасшифровки , СтандартнаяОбработка )

СтандартнаяОбработка = Ложь;

КомпоновщикМакет = Новый КомпоновщикМакетаКомпоновкиДанных ;

Макет = КомпоновщикМакет . Выполнить ( СхемаКомпоновкиДанных , КомпоновщикНастроек . Настройки , ДанныеРасшифровки ) ;

ПроцессорКомпоновк и = Новый ПроцессорКомпоновкиДанных ;

ПроцессорКомпоновки . Инициализировать ( Макет , , ДанныеРасшифровки ) ;

ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент ;

ПроцессорВывода . УстановитьДокумент ( ДокументРезультат ) ;

ПроцессорВывода . Вывести ( ПроцессорКомпоновки ) ;

//ДокументРезультат.ПоказатьУровеньГруппировокСтрок(XXXXX); //Здесь указываем УРОВЕНЬ группировки

ДокументРезультат . ПоказатьУровеньГруппировокСтрок ( 0 ) ;

КонецПроцедуры

Одноклассники

Все материалы и продукты на этом сайте опубликованы для целей ознакомления для зарегистрированных пользователей фирм производителей материала или продукта, или его авторов. Помните, что скачанные материалы или продукты, Вы используете на свой страх и риск. Автор и администрация этого сайта не несет никакой ответственности за использование этих материалов или продуктов третьими лицами. В случае, если вы используете один из перечисленных здесь материалов или продуктов, Вы обязаны официально приобрести его у фирмы производителя или автора.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *