Как применить формулу в excel ко всему столбцу
Перейти к содержимому

Как применить формулу в excel ко всему столбцу

  • автор:

Скопируйте формулу, перетащив его Excel для Mac

С помощью маркера заполнения можно быстро копировать формулы в смежные ячейки.

Маркер заполнения

При перетаскивании маркера в другие ячейки Excel показывает разные результаты для каждой ячейки.

Копирование формулы с помощью маркера заполнения

Курсор на маркере заполнения

  1. Выделите ячейку, которая содержит формулу для заполнения смежных ячеек.
  2. Поместите курсор в правый нижний угол, чтобы он принял вид знака плюс (+). Например:

Курсор, перетаскивающий вниз маркер заполнения

Перетащите маркер заполнения вниз, вверх или по ячейкам, которые нужно заполнить. В этом примере на рисунке ниже показано перетаскивание химок заливки вниз.

Показаны значения для заполненных ячеек

Когда вы отпустите маркер, формула будет автоматически применена к другим ячейкам.

Кнопка

Чтобы изменить способ заполнения ячеек, нажмите кнопку Параметры автозаполнения

Дополнительные сведения о копировании формул см. в статье Копирование и вставка формулы в другую ячейку или на другой лист.

  • Вы также можете нажать CTRL+D, чтобы заполнить формулу вниз по столбцу. Сначала выберите ячейку с формулой, которую нужно заполнить, а затем выберите ячейки под ней и нажмите CTRL+D.
  • Можно также нажать CTRL+R, чтобы заполнить формулой формулу справа в строке. Сначала вы выберите ячейку с формулой, которую нужно заполнить, а затем выберите ячейки справа от нее, а затем нажмите CTRL+R.

Если заполнение не работает

Иногда заполнение работает нормально, а в других случаях работает не так, как вы ожидаете. Поэтому важно проверить ссылки на ячейки в первой ячейке.

Ссылки на ячейки — это просто указатели на другие ячейки. Например, пусть первая ячейка содержит такую формулу:

A1 и B1 — относительные ссылки. Это означает, что при заполнении формулы вниз ссылки будут пошагово изменяться с A1, B1 на A2, B2 и так далее:

=СУММ(A1;B1)

=СУММ(A2;B2)

=СУММ(A3;B3)

В других случаях ссылки на другие ячейки могут не изменяться. Например, вы хотите, чтобы первая ссылка A1 оставалась фиксированной, а B1 изменялась при перетаскивании маркера заполнения. В этом случае необходимо ввести знак доллара ($) в первой ссылке: =СУММ($A$1;B1). При заполнении других ячеек Excel знак доллара должен продолжать нанося указатель на ячейку A1. Это может выглядеть таким образом:

=СУММ($A$1;B1)

=СУММ($A$1;B2)

=СУММ($A$1;B3)

Ссылки со знаками доллара ($) называются абсолютными. При заполнении ячеек вниз ссылка на A1 остается фиксированной, но ссылку B1 приложение Excel изменяет на B2 и B3.

Есть проблемы с отображением маркера заполнения?

Если маркер не отображается, возможно, он скрыт. Чтобы отобразить его:

  1. В меню Excel выберите пункт Параметры.
  2. Щелкните Правка.
  3. В разделе Параметры правки установите флажок Включить маркер заполнения и перетаскивание ячеек.

Если автоматическое вычисление в книге не работает, при заполнении ячеек формулы не пересчитыются.

Ниже описано, как его включить.

  1. В меню Excel выберите пункт Параметры.
  2. Щелкните Вычисление.
  3. Убедитесь,что в оке Параметры вычислений выбран параметр Автоматически.

Как использовать вычисляемые столбцы в таблице Excel

Вычисляемые столбцы в таблицах Excel упрощают ввод формул. Формула, введенная в одну ячейку столбца, автоматически распространяется на его остальную часть. При этом не приходится использовать заполнение или копирование. Это позволяет сэкономить время, особенно при наличии множества строк. То же самое происходит при изменении формулы: изменение также распространяется на все остальные ячейки вычисляемого столбца.

Примечание: Снимки экрана в этой статье получены в Excel 2016. Если вы используете другую версию, интерфейс может немного отличаться, но функции будут такими же.

Создание вычисляемого столбца

Добавление нового столбца путем ввода данных в пустой столбец справа от существующей таблицы

  1. Создайте таблицу. Если вы не знакомы с таблицами Excel, см. статью Общие сведения о таблицах Excel.
  2. Вставьте в таблицу новый столбец. Введите данные в столбец справа от таблицы, и Excel автоматически расширит ее. В этом примере мы создали новый столбец, введя «Итог» в ячейке D1.

Чтобы добавить столбец, на вкладке

Советы:

  • Вы также можете добавить столбец на вкладке Главная. Просто щелкните стрелку на кнопке Вставить и выберите команду Вставить столбцы таблицы слева.

Добавление формулы в ячейку таблицы, которая будет автоматически заполнена в других ячейках для создания вычисляемого столбца

Введите нужную формулу и нажмите клавишу ВВОД.

Пример формулы, которая использовалась для создания вычисляемого столбца в таблице

В этом случае мы ввели =СУММ(, а затем выбрали столбцы Кв1 и Кв2. В результате Excel создал следующую формулу: =СУММ(Таблица1[@[Кв1]:[Кв2]]). Такие формулы называются формулами со структурированными ссылками, и их можно использовать только в таблицах Excel. Структурированные ссылки позволяют использовать одну и ту же формулу в каждой строке. Обычная формула Excel выглядела бы как =СУММ(B2:C2), и ее было бы необходимо добавить в остальные ячейки путем копирования и вставки или заполнения. Дополнительные сведения о структурированных ссылках см. в статье Использование структурированных ссылок в таблицах Excel.
При нажатии клавиши ВВОД формула будет автоматически применена ко всем ячейкам столбца, которые находятся сверху и снизу от активной ячейки. Для каждой строки используется одна и та же формула, но поскольку это структурированная ссылка, Excel знает, на что она ссылается в каждой строке.

Команда для перезаписи существующих формул в вычисляемом столбце, когда одна формула отличается от остальных

  • При копировании формулы во все ячейки пустого столбца или заполнении его формулой он также становится вычисляемым.
  • Если ввести или переместить формулу в столбец, уже содержащий данные, это не приведет к автоматическому созданию вычисляемого столбца. Однако отобразится кнопка Параметры автозамены, с помощью которой можно перезаписать данные и создать вычисляемый столбец.

Команда для отмены вычисляемого столбца после ввода формулы

При вводе новой формулы, которая отличается от существующих в вычисляемом столбце, она будет автоматически применена к столбцу. Вы можете отменить обновление и оставить только одну новую формулу, используя кнопку Параметры автозамены. Обычно не рекомендуется этого делать, так как столбец может прекратить автоматически обновляться из-за того, что при добавлении новых строк будет неясно, какую формулу нужно к ним применять.

Создание исключений для вычисляемого столбца

В вычисляемый столбец можно включать формулы, отличающиеся от формулы столбца. Ячейки с такими формулами становятся исключениями и выделяются в таблице. Это позволяет выявлять и устранять несоответствия, возникшие по ошибке.

Уведомление о несогласованной формуле в таблице Excel

Примечание: Исключения вычисляемого столбца возникают в результате следующих операций.

  • При вводе в ячейку вычисляемого столбца данных, отличных от формулы.
  • Ввод формулы в ячейку вычисляемого столбца и нажатие кнопки Отменить

Примечание: Если скопированные данные содержат формулу, она заменяет данные в вычисляемом столбце.
Примечание: В этом случае исключение не помечается.

Уведомление об ошибке отображается только в том случае, если включена фоновая проверка ошибок. Если вы не видите сообщение об ошибке, откройте Файл > Параметры > Формулы и убедитесь, что флажок Включить фоновую проверку ошибок установлен.

Кнопка Office 2007

    Если вы используете Excel 2007, нажмите кнопку Office

Прекращение создания вычисляемых столбцов

Параметр автоматического заполнения формул для создания вычисляемых столбцов в таблице Excel по умолчанию включен. Если не нужно, чтобы приложение Excel создавало вычисляемые столбцы при вводе формул в столбцы таблицы, можно выключить параметр заполнения формул. Если вы не хотите выключать этот параметр, но не всегда при работе с таблицей хотите создавать вычисляемые столбцы, в этом случае можно прекратить автоматическое создание вычисляемых столбцов.

Кнопка Office 2007

    Включение и выключение вычисляемых столбцов
    На вкладке Файл нажмите кнопку Параметры. Если вы используете Excel 2007, нажмите кнопку Office

и выберите Параметры Excel.

  • Выберите категорию Правописание.
  • В разделе Параметры автозамены нажмите кнопку Параметры автозамены
  • Откройте вкладку Автоформат при вводе.
  • В разделе Автоматически в ходе работы установите или снимите флажок Создать вычисляемые столбцы, заполнив таблицы формулами, чтобы включить или выключить этот параметр.

    Совет: Вы можете также щелкнуть кнопку Параметры автозамены, которая отобразится в столбце таблицы после ввода формулы. Нажмите кнопку Параметры автозамены, а затем снимите флажок Создать вычисляемые столбцы, заполнив таблицы формулами, чтобы отключить этот параметр.

    Если вы используете Mac, выберите Excel в главном меню, а затем щелкните Параметры > Формулы и списки > Таблицы и фильтры > Автоматически заполнять формулы.

    Вычисление значений в сводной таблице

    Вы также можете создавать настраиваемые вычисляемые поля со сводными таблицами, где создается одна формула, а Затем Excel применяет ее ко всему столбцу. Дополнительные сведения о вычислении значений в сводной таблице.

    Дополнительные сведения

    Вы всегда можете задать вопрос эксперту в Excel Tech Community или получить поддержку в сообществах.

    Как применить формулу в excel ко всему столбцу

    Как применить(преобразовать, видоизменить. ) формулу ко всему или диапазону (с2-с101) столбца
    Например, для ячейки С2 формула =B2/A2*100-100
    для С3 =B3/A3*100-100
    для С4 =B4/A4*100-100
    .
    для С101 =B101/A101*100-100

    04.10.2012 18:35:52
    Двойной клик по правому нижнему углу ячейки С2.
    Пользователь
    Сообщений: 5138 Регистрация: 22.12.2012
    04.10.2012 18:39:38

    >>> Двойной клик по правому нижнему углу ячейки С2.. поправочка
    когда курсор изменит вид на черный маленький крестик.
    или зажимаем левую кнопку на черном крестике и просто тянем вниз.

    Страницы: 1
    Читают тему

    © Николай Павлов, Planetaexcel, 2006-2023
    info@planetaexcel.ru

    Использование любых материалов сайта допускается строго с указанием прямой ссылки на источник, упоминанием названия сайта, имени автора и неизменности исходного текста и иллюстраций.

    ООО «Планета Эксел»
    ИНН 7735603520
    ОГРН 1147746834949
    ИП Павлов Николай Владимирович
    ИНН 633015842586
    ОГРНИП 310633031600071

    Как в Экселе протянуть формулу по строке или столбцу: 5 способов

    Как скачать приложение Аэрофлот на «Андроид»

    Работая с таблицами Excel, пользователям часто приходится использовать для вычислений одни и те же формулы. Причем расположенные не просто рядом, а вдоль всей строки или столбца. Работу можно заметно упростить — для этого надо познакомиться с различными способами, как протянуть формулу в Эксель в нужном направлении.

    Как в Экселе протянуть формулу по строке или столбцу: 5 способов

    Наши советы помогут работать с обычными суммами значений в выбранном диапазоне ячеек или сложными вычислениями с десятками аргументов. Главное, что при большом количестве формул их будет легко расположить в нужных местах.

    1 Простое протягивание формулы

    Это самый простой и привычный для многих пользователей способ распространения формулы сразу на несколько ячеек строки или столбца. Он требует выполнения следующих действий:

    • В первую ячейку с одной из сторон (например, сверху) надо записать нужную формулу и нажать Enter.
    • После появления рассчитанного по формуле значения навести курсор в нижний правый угол ячейки. Подождать, пока толстый белый крестик не превратиться в тонкий черный.
    • Нажать на крестик и, удерживая его, протянуть формулу в нужном направлении. В указанном примере — вниз.

    Как в Экселе протянуть формулу по строке или столбцу: 5 способов

    Как в Экселе протянуть формулу по строке или столбцу: 5 способов

    Как в Экселе протянуть формулу по строке или столбцу: 5 способов

    Аргументы в формуле будут изменяться соответственно новому расположению. И если в самой первой ячейке это были F7 и G7, в последней позиции столбца это будет уже F12 и G12. Соответственно, если начинать распространять формулы по строкам, изменяться будут не цифры, а буквы в обозначениях ячеек.

    Способ отличается простотой и высокой скоростью. Но не всегда подходит для больших таблиц. Так, если в столбце несколько сотен или даже тысяч значений, формулу проще растягивать другими способами, чтобы сэкономить время. Один из них — автоматическое копирование, требующее всего лишь двойного клика кнопкой мыши.

    2 Быстрое автозаполнение

    Еще один способ в Excel протянуть формулу до конца столбца с более высокой по сравнению с первой методикой скоростью. Требует от пользователя применить такие действия:

    • Ввести в верхнюю ячейку формулу, в которой применяются аргументы из соседних столбцов. Нажать кнопку Enter.
    • Навести курсор на правый нижний угол, чтобы он приобрел форму черного крестика.
    • Кликнуть два раза по нижнему правому углу ячейки. Результатом станет автоматическое распространение формулы по столбцу с соответствующим изменением аргументов.
  • Добавить комментарий

    Ваш адрес email не будет опубликован. Обязательные поля помечены *