Как посмотреть список листов в книге excel
Перейти к содержимому

Как посмотреть список листов в книге excel

  • автор:

Как вывести список листов в Excel

Иногда необходимо вывести список листов Excel в указанный диапазон. Если листов не много, то это достаточно просто сделать. Однако, если листов более 10, то задача займет много времени.

C помощью надстройки VBA-Excel можно выводить список выбранных листов книги в указанную ячейку.

Вывести список листов excel

Вывести список листов в ячейку можно следующим способом:

  1. Перейти на вкладку VBA-Excel (доступна после установки).
  2. В меню Диспетчеры выбрать пункт Диспетчер листов.
    Вызов диспетчера листов
  3. Выбрать команду Список листов
    Выбор команды Список листов в диспетчере
  4. В диалоговом окне указать ячейку, в которую будет выводиться список листов. Вы можете вывести как все листы книги, так и те, которые вы выбрали в диспетчере листов.
    Вывод перечня листов
  5. Нажать кнопку Создать список

Надстройка
VBA-Excel

Надстройка для Excel содержит большой набор полезных функций, с помощью которых вы значительно сократите время и увеличите скорость работы с программой.

Как посмотреть список листов в книге excel

Данная команда создает новый лист и выводит в данном листе список листов рабочей книги, за исключением созданного листа со списком:

Получить список листов книги

Чтобы воспользоваться данной командой перейдите во вкладку «ЁXCEL» Главного меню, нажмите кнопку «Листы» и выберите команду «Получить список листов книги»:

В открывшемся диалоговом окне выберите один из вариантов отображения списка листов и нажмите кнопку «ОК»:

Для отмены операции нажмите кнопку отмены:

Как посмотреть список листов в книге excel

необходимо на первом листе книги начиная с определенной ячейки (R5C1) вывести список всех видимых листов книги (при нажатии на имя листа должен быть осуществлен переход к этому листу).
на данный момент имею только макрос, который на чистый лист выводит список листов с гиперссылками на них, но не с определенной ячейки, а с первой строки.

буду очень благодарен за любую помощь.

Пользователь
24.10.2018 10:11:58

xander74, Здраствуйте!
1. Вы не в первый раз тут, а с правилами еще не ознакомились? файл пример где? да и с темой думаю модераторы не согласятся
2. Поиском не пользовались? В приемах есть как раз разбор Вашего вопроса https://www.planetaexcel.ru/techniques/12/60/
3. Выкладываю формулу из рабочего файла, мб и разберетесь, воспользуйтесь справкой из приема

=ЕСЛИОШИБКА(ГИПЕРССЫЛКА("#'"&ЕСЛИОШИБКА(ИНДЕКС(Оглавление;B6+3);"")&"'!A1";ИНДЕКС(ДВССЫЛ("'"&ЕСЛИОШИБКА(ИНДЕКС(Оглавление;B6+3);"")&"'"&"!A1:F110");10;5));"")

В жизни нет ничего невозможного! Есть только недостаток знаний и умений.
Пользователь
24.10.2018 10:26:43
Александр, ну что Вы так суровы?

Цитата
xander74 написал же:
на данный момент имею только макрос

А файла ещё нет. Только макрос.

«Видала я котов без улыбок, но улыбку без кота…»

Пользователь
24.10.2018 11:00:56
файл с макросом прикрепил
Прикрепленные файлы

  • Книга1.xlsm (16.38 КБ)

Пользователь
24.10.2018 12:10:20

xander74, и куда надо переходить? Все листы пустые. Заполните листы и ручками пропишите куда надо перейти, а там и макрос можно довести до требуемого результата.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Пользователь
24.10.2018 12:44:58
Один вопрос — одна тема. Суммы — не в эту тему
Пользователь
24.10.2018 14:38:54

переходить надо на соответствующий лист — это работает. надо чтобы во втором столбце была сумма всего третьего столбца этого листа (на который указывает гиперссылка). и вывод имен листов необходим начиная с указанной мною ячейки, а не с 1,1 нового листа.

Пользователь
24.10.2018 14:41:12
Суммы — сообщение №6
Пользователь
24.10.2018 14:50:29

просто сумму определенного столбца, определенного (или всех листов) я тоже могу вывести в ячейку. я не могу сделать чтобы сумма конкретной страницы была написана напротив имени этой страницы. просто в ручную я могу в столбце напротив строки поставить формулу, которая будет складывать ячейки соответствующего листа =СУММ(). хочется сделать на vba, чтобы в дальнейшем при изменении значений столбцов этих листов суммы пересчитывались. например если пользователь создаст дополнительные листы, и будет заполнять в них определенный столбец, затем выполнит макрос, — который выведет имена всех листов в книге и напротив суммы третьих столбцов этих листов.

Прикрепленные файлы

  • Книга2.xlsm (17.01 КБ)

Исчезли ярлычки листов

Если в нижней части книги не отображаются ярлычки листов, это может быть вызвано несколькими причинами. В таблице ниже приведены их описания и способы устранения.

Примечание: Представленные в этой статье изображения созданы в Excel 2016. Если вы используете другую версию, интерфейс может немного отличаться, но функции будут такими же (если не указано иное).

Ярлычки скрыты из-за изменения размеров окон.

Ярлычки исчезают, когда строка состояния находится под строкой формул

Строка состояния находится под строкой формул.

Попробуйте увеличить размер окна, чтобы открыть вкладки. Просто дважды щелкните заголовок окна.

Если ярлычки по-прежнему не отображаются, щелкните Вид > Упорядочить все > Рядом > ОК.

Параметр Показывать ярлычки листов отключен.

Сначала проверьте, действительно ли параметр Показывать ярлычки листов включен. Вот как это сделать:

Настройка

    Для других версий Excel: выберите Файл >Параметры >Дополнительно и убедитесь, что в разделе Показать параметры для следующей книги установлен флажок Показывать ярлычки листов.

Ярлычки перекрываются горизонтальной полосой прокрутки.

Наведите указатель мыши на край полосы прокрутки и удерживайте его, пока не появится двусторонняя стрелка (см. рисунок). Щелкните и перетащите стрелку вправо, пока не появится название ярлычка целиком и остальные ярлычки.

Чтобы показать ярлычки, перетащите двунаправленную стрелку вправо

Чтобы отобразить лист, щелкните правой кнопкой мыши любой видимый ярлычок и выберите команду Отобразить. В диалоговом окне Вывод на экран скрытого листа выберите лист, который нужно отобразить, и нажмите кнопку ОК.

Отображение скрытого листа

Дополнительные сведения

Вы всегда можете задать вопрос эксперту в Excel Tech Community или получить поддержку в сообществах.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *