Характеристика статьирасходов как заполнить программно
Перейти к содержимому

Характеристика статьирасходов как заполнить программно

  • автор:

Заполнение справочников «Статьи расходов» в «1С:ЕRP», «1С:Комплексная автоматизация»

Для планирования бюджета компаний, а также для принятия своевременных решений необходимо вести оптимизацию всех расходов на предприятии, используя при этом статьи расходов.

Для создания статей расходов заходим в раздел «Финансовый результат и контроллинг» — «Статьи расходов».

Статьи расходов в 1С:ЕRP

По Команде «Создать» создадим «Статью расходов» — это классификатор, в разрезе которого можно проанализировать разные виды расходов бюджета.

Статьи расходов в 1С:ЕRP

На вкладке «Основное» заполняются следующие данные:

1. Наименование – название статьи для назначения, где она будет применяться.

2. Описание – текстовое поле для фиксации нужной информации.

3. Тип расходов – выбираем из типового перечня расходов.

4. Группа статей – место расположения в папке справочника «Статей расходов».

5. Расходы по деятельности – зависит от деятельности компании.

6. Распределять в рег. учете и упр.учете — заполняются аналогично друг другу.

Статьи расходов в 1С:ЕRP

Выбор конкретного типа расходов определяет в дальнейшем доступные виды аналитик расходов и варианты распределения расходов для целей управленческого и регламентированного учета.

1. Расходы по приобретению товаров – это расходы, связанные с доп. расходами по приобретению ТМЦ, которые не относятся к ТЗР.

2. Расходы на складское хранение и обработку – связаны с перемещением ТМЦ между складами, по сборке/разборке, с хранением, списанием материалов на собственные нужды.

3. Расходы на продажу товаров – связаны с реализацией товаров, работ, услуг.

4. Производственные расходы – связаны с производством продукции и относятся на себестоимость выпускаемой продукции.

5. Формирование стоимости внеоборотных активов — связаны с созданием и/или приобретением, модернизацией ВНА.

6. Прочие операционные и внереализационные расходы – это те расходы, которые связаны:

— с предоставлением за плату во временное пользование (или временное владение) активов организации;

— с предоставлением за плату прав, возникающих из патентов на изобретения, промышленные образцы и других видов интеллектуальной собственности;

— с участием в уставных капиталах других организаций;

— с продажей, выбытием и прочим списанием основных средств и иных активов, отличных от денежных средств (кроме иностранной валюты), товаров, продукции;

— с оплатой услуг, оказываемых кредитными организациями;

— штрафы, пени, неустойки за нарушение условий договоров;

— возмещение причиненных организацией убытков;

— суммы дебиторской задолженности, по которым истек срок исковой давности, других долгов, нереальных для взыскания;

— сумма уценки активов;

— перечисление средств (взносов, выплат и т.д.), связанных с благотворительной деятельностью, расходы на осуществление спортивных мероприятий, отдыха, развлечений, мероприятий культурно-просветительского характера и иных аналогичных мероприятий.

Выбор конкретного типа расходов в 1С:ЕRP

Отнесение расходов к деятельности:

1. Расходы по деятельности «Основной» — если для одного из видов экономической деятельности значение критерия составит 50 и более %, то этот вид деятельности следует считать основным.

2. Расходы по деятельности «Прочей» — это деятельность предприятия, которая не связана с основной деятельностью. Это операционные и внереализационные расходы.

3. Расходы по деятельности «Основной и Прочей» — совокупность основной и прочей деятельности.

Распределение в рег. учете и упр. учете:

1. На себестоимость товаров – вариант распределения «На себестоимость товаров» позволяет увеличить стоимость материальных ценностей на сумму дополнительных расходов.

2. На финансовый результат – этот вариант распределения затрат позволяет обеспечивать принятие к учету затрат, содержание которых связано с распределением расходов по направлениям деятельности.

3. На расходы будущих периодов — этот вариант распределения позволяет отнести затраты, которые включены в себестоимость, на определенные периоды.

4. Не распределять – расходы по такой статье автоматически не распределяются.

Распределение затрат в 1С:ЕRP

Применение правил в способах распределения расходов:

1. «На себестоимость товаров», выбираем из списка необходимое нам правило распределения:

  • Пропорционально количеству номенклатуры — базу распределения определяют по количеству выбранной номенклатуры.
  • Пропорционально себестоимости номенклатуры — базу распределения определяют по стоимости выбранной номенклатуры.
  • Пропорционально весу номенклатуры.
  • Пропорционально объему номенклатуры.

Способы распределения расходов в 1С:ЕRP

2. «На финансовый результат», выбираем из списка необходимое нам правило или создаем его:

Способы распределения расходов в 1С:ЕRP

При создании «Правила распределения между направлениями деятельности» указываем Наименование, выбираем вариант «Правило распределения».

  • Пропорционально выручке от продаж – это сумма выручки от продаж организации (прочие доходы), которая будет распределена по конкретным видам деятельности.
  • Пропорционально себестоимости продаж – это себестоимость (прочие расходы) продаж, которая будет распределена по конкретным видам деятельности.
  • Пропорционально валовой прибыли – это сумма выручки от продаж за минусом себестоимости продаж, распределенная по конкретным видам деятельности.
  • Пропорционально коэффициентам — это указание вручную коэффициентов в табличной части по каждому виду деятельности, относительно друг друга.

Способы распределения расходов в 1С:ЕRP

3. На «Расходы будущих периодов». Выбираем статью расходов из списка.

Способы распределения расходов в 1С:ЕRP

Суммы затрат могут формироваться в разрезе различных типов аналитики расходов:

  • Заказы поставщику, ввод остатков, передача товаров между организациями – это сумма затрат, которая увеличивает стоимость остатков номенклатуры, указанной в документах соответствующего типа.
  • Приобретение товаров и услуг — это сумма затрат, которая увеличивает стоимость остатков номенклатуры, оприходованной по выбранным документам «Поступление товаров и услуг».

Использование галочки «Контролировать заполнение аналитики» позволяет контролировать обязательное заполнение в документе реквизита «Аналитика».

Суммы затрат в 1С:ЕRP

На вкладке «Регламентированный учет и МФУ» заполняются следующие данные:

Устанавливаем или не устанавливаем галочку в «Принятии к налоговому учету по налогу на прибыль» и выбираем счет учета.

Регламентированный учет и МФУ в 1С:ЕRP

На вкладке «Ограничение использования» заполняются следующие данные:

При установке галочки в «Хозяйственных операциях» выбираем те операции, которые хотим видеть в документах.

Статьи расходов в 1С:ЕRP

Душамбаева Марина
Консультант Компании «АНТ-ХИЛЛ»
При цитировании статей или заметок
ссылка на сайт автора обязательна
Накопились вопросы и нужна помощь?
С удовольствием на все ответим и поможем всё настроить!
звоните!

(473) 202-20-10 (495) 145-94-84

© 2024 1С-ФРАНЧАЙЗИ
НАШИ СОЦСЕТИ

  • БУХГАЛТЕРСКИЙ УЧЕТ
  • CRM
  • ДОКУМЕНТООБОРОТ
  • РЕСТОРАНЫ И ГОСТИНИЦЫ
  • МАРКИРОВКА

Г. ВОРОНЕЖ,
БУЛЬВАР ПОБЕДЫ, 50

Как настроить статьи затрат в 1С 8.3 Бухгалтерия?

Анна Викулина

Оперативная помощь по 1С — от простых консультаций до сложных внедрений. Протестируйте качество нашей работы — получите первую консультацию в подарок.

от 800 руб.

Любой бухгалтер знает, что для ведения учета в бухгалтерской программе 1С используется система справочников. В этой статье мы остановимся и подробнее рассмотрим один из них, так называемый справочник «Статьи затрат»*, а также счета затрат, их классификацию и настройку на примере работы с одним из самых популярных бухгалтерских решений – 1С:Бухгалтерия 8.3.

*Статьи затрат – это деление по видам затрат для анализа состава расходования средств.

Для отнесения расходов в бухгалтерском учете используются следующие бухгалтерские счета затрат: 20, 23, 25, 26, 29, 44, 91. Все они предназначены для обобщения информации.

Конкретизируем, какой именно:

20/Основное производство: данные о затратах основного производства. В дебет данного счета относятся прямые расходы, связанные с выпуском основной продукции, выполняемыми работами, оказываемыми услугами. Также сюда относятся косвенные расходы со счетов 25 и 26, и затраты завершенного вспомогательного производства со сч.23

23/Вспомогательные производства: сведения о затратах вспомогательных производств.

25/Общепроизводственные расходы: информация о расходах по обслуживанию основных и вспомогательных производств организации.

26/Общехозяйственные расходы: обобщенные управленческие расходы непосредственно не связанные с производственным процессом.

29/Обслуживающие производства и хозяйства: данные о затратах, понесенных обслуживающими производствами и хозяйствами.

44/Расходы на продажу: расходы, связанные с продажей продукции, товаров, работ и услуг.

91/Прочие доходы и расходы: соответственно.

При этом по данным счетам можно вести аналитический учет* в разрезе статей затрат.

*Аналитический учет – это учет, который ведется на счетах бухгалтерского учета и позволяет группировать детальную информацию о хозяйственных операциях. Ведется в стоимостных и натуральных показателях.

Для ведения аналитического учета на затратных счетах в программе используются различные справочники: статьи затрат, подразделения, номенклатурные группы, прочие доходы и расходы.

Субконто «статья затрат» к счетам в 1С необходимо для разделения по видам расходов. Используется в учете для анализа состава затрат, также используется и для целей налогового учета и классификации расходов по видам затрат НУ.

Для затратных счетов: 20, 23, 25, 26, 29, 44 в 1С используется единый справочник «Статьи затрат». Для аналитического учета прочих доходов и расходов используется справочник: «Прочие доходы и расходы».

На счете 20 (а также 23 и 29) аналитический учет ведется по подразделениям (субконто «подразделения»), видам выпускаемой продукции (субконто «номенклатурные группы») и видам затрат (субконто «статьи затрат»).

На счетах: 25, 26, 44 аналитический учет ведется по подразделениям и видам затрат.

Если речь идет о 91 счете, то можно добавить, что на нем аналитический учет ведется по видам прочих доходов и расходов.

При этом каждое подразделение, каждый вид продукции и каждый вид затрат это элемент соответствующего справочника.

В 1С Бухгалтерия 8.3 аналитика к счету выглядит следующим образом (например, к счету 20.01):

Аналитика к счету 20.01

Рассмотрим, каким образом осуществляется настройка статей затрат в 1С

Для того чтобы открыть справочник, необходимо пройти в меню: Справочники – далее в раздел Доходы и расходы – далее выбрать ссылку статьи затрат. При этом откроется окно справочника. Если у вас возникли сложности при работе с программой или вам необходимо получить 1С консультацию, обращайтесь к нашим специалистам по телефону, а также оставляйте заявки на нашем сайте. Мы свяжемся с вами в кратчайшие сроки.

Справочник является иерархическим. Для удобства при большом количестве статей можно создавать группы, группировать статьи по различным признакам, по организациям (если в одной информационной базе ведется учет по нескольким организациям). Кроме того группы справочника могут включать в себя и другие группы, создавая тем самым многоуровневую иерархическую структуру.

Справочник

Группы справочника

В новых информационных базах справочник заполнен значениями по умолчанию (предопределенными элементами) самыми распространенными видами затрат:

  • Амортизационная премия
  • Оплата труда
  • Оплата труда (ЕНВД)
  • Прочие затраты
  • Списание материалов
  • Списание НДС
  • Списание НДС (ЕНВД)
  • Услуги комиссионеров

От статей, введенных пользователем, их можно отличить по иконке . Корректировать или удалять их не рекомендуется.

В зависимости от потребностей и специфики предприятия пользователи могут самостоятельно добавить статьи затрат в справочник (создать статью затрат в 1С), а могут обратиться к профессионалам в рамках комплексного обслуживания 1С.

В случае самостоятельной работы, рекомендуем обратить внимание, что не нужно вводить схожие наименования, так как это может привести к некорректной аналитике в учете и «раздутию» справочника. Структуру затрат предприятия следует продумать заранее, по возможности объединив мелкие однотипные расходы в более крупные группы. Вводить их в справочник рекомендуется именно в той структуре, в которой они используются в отчетах для экономистов и управленцев. Затраты классифицируют исходя из целей, по которым производится расчет себестоимости.

Эти работы могут потребовать участия аналитика и специалиста по работе со справочниками. Прибегнув к услугам комплексного обслуживания 1С на этапе внедрения программы или позже – во время ее настройки, вы гарантированно получите полностью готовую к работе программу с настройками, полностью учитывающими специфику вашего предприятия.

Группировка затрат по экономическим элементам

Используется для анализа результатов предприятия в части финансов. Отличается от классификации по статьям тем, что все расходы распределяются по видам, характеризующим их экономическое содержание. В каждый экономический элемент входит обширный перечень статей однородных по их экономическому содержанию. Например, элемент материальные расходы. В него входят такие статьи, как сырье, топливо, инструмент и т.д.

Подобная классификация позволяет определить структуру себестоимости и удельный вес отдельного элемента во всей себестоимости. Группировка по экономическим элементам может выглядеть следующим образом:

  • Материальны расходы
  • Амортизация
  • Расходы на оплату труда
  • Амортизация
  • Отчисления на соц. Нужды
  • Прочие расходы

Так как в 1С:Бухгалтерия 8.3. справочник «Статьи затрат» является иерархическим, то можно создать группы по экономическим элементам.

Однако группировка по элементам затрат не позволяет определить себестоимость единицы продукции. Для этой цели служит группировка затрат по калькуляционным статьям.

Группировка по калькуляционным статьям расходов

Объединяет затраты по признаку места их возникновения и назначения. Ее применяют при составлении калькуляции себестоимости. Само подразделение на калькуляционные статьи может быть различным в зависимости от целей калькулирования. Классификация затрат по статьям калькуляции позволяет определить себестоимость единицы продукции. Группировка затрат по статьям калькуляции может иметь следующий вид:

  • Сырье, основные материалы, полуфабрикаты, комплектующие
  • Вспомогательные материалы
  • Основная заработная плата
  • Дополнительная заработная плата
  • Отчисления на социальные нужды
  • Топливо
  • Энергия

Каждая калькуляционная статья вводится в справочник как отдельный элемент.

При создании нового элемента справочника в 1С необходимо заполнить следующие реквизиты:

Реквизиты нового элемента справочника

  • Наименование

Присвоить название отображающее суть расхода.

Заполнение данного реквизита не является обязательным. Указывается, если используется иерархия в справочнике. В таком случае, требуется указать, к какой группе относится статья.

Является обязательным для заполнения реквизитом. Информация, отраженная в данном реквизите, используется в налоговом учете. Важно корректно указать вид затрат, т.к. по нему будут отражаться расходы по налоговому учету для целей налога на прибыль. Выбирается из существующего списка, редактировать который нельзя. Акцентируем внимание на вид расхода «Не учитываемые в целях налогообложения». Он выбирается в том случае, если в бухгалтерском учете расходы понесены и отражаются на затратах, а в целях исчисления налога на прибыль к расходам, уменьшающим базу по налогу на прибыль, их отнести нельзя.

  • Использовать по умолчанию

Реквизит не является обязательным для заполнения. Можно указать документ, в который данная статья будет подставляться по умолчанию. Также это поле можно не заполнять.

После ввода новой статьи она отобразится в списке справочника.

Новая статья в списке справочника

Уже введенные статьи затрат можно корректировать или помечать на удаление. Делать это следует крайне осторожно ввиду того, что данная статья уже могла использоваться в документах. Если обойтись без корректировки нельзя, то после изменения статьи следует заново провести документы.

Чтобы увидеть как сгруппировались затраты по статьям, следует сформировать отчет по статьям затрат в 1С 8.3. Для этого подойдет, например, оборотно-сальдовая ведомость по счету или Анализ субконто.

Формирование отчета по статьям затрат

В данной статье мы рассмотрели заполнение одного из основных и наиболее важных справочников 1С. Его корректное и безошибочное заполнение влияет на формирование достоверной отчетности предприятия.

УФ программно заполнить колонку Характеристика в ТЧ товары

Коллеги, доброго времени суток.
Конфигурация Рарус. Розница Ювелирный магазин. 2.2.6.33
По кнопке заполнить должна заполняться ТЧ Товары в документе Перемещение товаров, однако в колонку характеристика значение не подставляется. Запрос проверил в консоли, характеристику находит.
Прошу помочь разобраться

&НаСервере Процедура ЗаполнитьНаСервере() ЯчейкаВладелецНаименование = Объект.ПаллетОтправитель; Запрос = Новый Запрос("ВЫБРАТЬ | ор_РасположениеНоменклатуры.Номенклатура КАК Номенклатура, | ор_РасположениеНоменклатуры.Характеристика КАК Характеристика |ИЗ | РегистрСведений.ор_РасположениеНоменклатуры КАК ор_РасположениеНоменклатуры |ГДЕ | ор_РасположениеНоменклатуры.Ячейка.Владелец.Ссылка = &Ссылка"); Запрос.УстановитьПараметр("ссылка",ЯчейкаВладелецНаименование); РезультатЗапроса = Запрос.Выполнить(); Выборка = РезультатЗапроса.Выбрать(); Пока Выборка.Следующий() Цикл новаястр = Объект.Товары.Добавить(); новаястр.Номенклатура = Выборка.Номенклатура; новаястр.Характеристика =Выборка.Характеристика; новаястр.КоличествоУпаковок = ("1"); Конеццикла; КонецПроцедуры

По теме из базы знаний

  • Перенос данных из УПП 1.3 / КА 1.1 в БП 3.0
  • 50+ советов для успешной сдачи 1С: Специалист по платформе
  • Отчет «Полный анализ себестоимости выпущенной продукции» для 1С:ERP (ЕРП), 1С:КА, 1С:ERP УХ
  • Отчет «Полный анализ себестоимости реализованной продукции» для 1С:ERP (ЕРП), 1С:КА, 1С:ERP УХ
  • Материально-производственный отчет в 1С:ЕРП, КА, 1С:ERP УХ

Найденные решения
15. infostartuser1 10.11.17 18:28 Сейчас в теме

<характеристики не используются>— ввел в глобальный поиск.
нашел в формедокумента данную строчку в условном оформлении,
отключил — характеристики заполняются)

user705522_constantin_h; + 1 – Ответить
Остальные ответы

  • Дата
  • Дата
  • Рейтинг всех уровней
  • Рейтинг 1-го уровня
  • Древо развёрнутое
  • Древо свернутое

Свернуть все
2. Denis_CFO 48 27.10.17 09:14 Сейчас в теме
(1) типы в таблице не совпадают?
3. infostartuser1 27.10.17 09:19 Сейчас в теме
(2)новичок, не понимаю)
4. Denis_CFO 48 27.10.17 09:20 Сейчас в теме

новаястр.Характеристика

тип поля какой, откуда данные ожидает получить?
5. infostartuser1 27.10.17 09:24 Сейчас в теме
(4)Про это спрашиваете?
Прикрепленные файлы:
6. Denis_CFO 48 27.10.17 09:26 Сейчас в теме
(5) Да. А в запросе
ор_РасположениеНоменклатуры.Характеристика КАК Характеристика
7. infostartuser1 27.10.17 09:28 Сейчас в теме

(6) Спасибо, понял. Но даже если пишу ор_РасположениеНоменклатуры.Характеристика.Ссылка КАК Характеристика все равно не подставляет

Прикрепленные файлы:
8. Denis_CFO 48 27.10.17 09:32 Сейчас в теме
ор_РасположениеНоменклатуры.Характеристика.Ссылка
а это справочник ХарактристикиНоменклатуры?
9. infostartuser1 27.10.17 09:33 Сейчас в теме
10. Denis_CFO 48 27.10.17 09:39 Сейчас в теме
(9) а на точке останова, когда цикл работает, это поле заполняется?
11. infostartuser1 27.10.17 09:44 Сейчас в теме
Прикрепленные файлы:
12. Denis_CFO 48 27.10.17 11:00 Сейчас в теме

(11) Все правильно. Тогда смотрите в процедуре при ОткрытииФормы, видимо там что-то меняет, либо ПриЗаписи.

13. infostartuser1 27.10.17 12:21 Сейчас в теме
Коллега, уже третий день смотрю код формы. Не за что заецпиться.
(12)

&НаКлиенте Процедура ПриОткрытии(Отказ) // ПодключаемоеОборудование МенеджерОборудованияКлиент.НачатьПодключениеОборудованиеПриОткрытииФормы(Неопределено, ЭтотОбъект, "СканерШтрихкода, СчитывательМагнитныхКарт"); // Конец ПодключаемоеОборудование Если Не Объект.Ссылка.Пустая() Тогда ПроверитьВыводНапоминанияЕГАИС(); КонецЕсли; // СтандартныеПодсистемы.ПодключаемыеКоманды ПодключаемыеКомандыКлиент.НачатьОбновлениеКоманд(ЭтотОбъект); // Конец СтандартныеПодсистемы.ПодключаемыеКоманды КонецПроцедуры
&НаСервере Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка) // Пропускаем инициализацию, чтобы гарантировать получение формы при передаче параметра "АвтоТест". Если Параметры.Свойство("АвтоТест") Тогда Возврат; КонецЕсли; УстановитьУсловноеОформление(); ВерсионированиеОбъектов.ПриСозданииНаСервере(ЭтотОбъект); ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект); ДополнительныеКолонкиНоменклатуры = ЗначениеНастроекПовтИсп.ПолучитьЗначениеКонстанты("ДополнительнаяКолонкаПриОтображенииНоменклатуры"); ОбщегоНазначенияРТ.ЗаполнитьШапкуДокумента(Объект,КартинкаСостоянияДокумента,Элементы.КартинкаСостоянияДокумента.Подсказка,РазрешеноПроведение); ор_ОбщегоНазначенияСервер.СоздатьРеквизитыФормыПодписиДокументов(ЭтотОбъект); ПараметрыУказанияСерий = Новый ФиксированнаяСтруктура(Документы.ПеремещениеТоваров.ПараметрыУказанияСерий(Объект)); Если НЕ ЗначениеЗаполнено(Объект.ДокументОснование) Тогда Элементы.ДокументОснование.Видимость = Ложь; Элементы.ПредставлениеДокументаОснования.Видимость = Ложь; Иначе ОснованиеОбъект = Объект.ДокументОснование.ПолучитьОбъект(); Если ОснованиеОбъект = Неопределено Тогда Элементы.ДокументОснование.Видимость = Ложь; Иначе Элементы.ПредставлениеДокументаОснования.Видимость = Ложь; КонецЕсли; КонецЕсли; ЕстьАлкогольнаяПродукцияЕГАИС = Ложь; Для Каждого СтрокаТовары Из Объект.Товары Цикл Если СтрокаТовары.НеобходимостьВводаСправкиНаАлкоголь Тогда ЕстьАлкогольнаяПродукцияЕГАИС = Истина; Прервать; КонецЕсли; КонецЦикла; Если НЕ ЗначениеЗаполнено(Объект.Ссылка) Тогда ТипУслуга = Перечисления.ТипыНоменклатуры.Услуга; ОбработкаТабличнойЧастиТоварыСервер.ЗаполнитьТипНоменклатурыВТЧСервер(Объект.Товары); ОбработкаТабличнойЧастиТоварыСервер.ЗаполнитьПризнакИспользованияХарактеристик(Объект.Товары); ОбработкаТабличнойЧастиТоварыСервер.ЗаполнитьИспользоватьСерийныеНомераВТЧСервер(Объект.Товары); ОбработкаТабличнойЧастиТоварыСервер.ЗаполнитьСтатусыУказанияСерий(Объект,ПараметрыУказанияСерий); УправлениеЭлементамиФормыНаСервере(); УстановитьСостояниеОтклонениеПриПеремещении(); ОбработкаТабличнойЧастиТоварыКлиентСервер.ОбновитьСтатусыСерийИПодарочныхСертификатов(Объект.Товары); ОбновитьИтоговыеПоказатели(ЭтотОбъект); ОбработкаТабличнойЧастиТоварыСервер.ЗаполнитьНеобходимостьВводаСправкиНаАлкоголь(Объект.Товары); КонецЕсли; ИспользоватьПередачиТоваровМеждуОрганизациями = ЗначениеНастроекПовтИсп.ПолучитьЗначениеКонстанты("ИспользоватьПередачиТоваровМеждуОрганизациями") И ЗначениеЗаполнено(Объект.ДокументОснование) И ТипЗнч(Объект.ДокументОснование) = Тип("ДокументСсылка.ПередачаТоваровМеждуОрганизациями"); ПодключаемоеОборудованиеРТВызовСервера.НастроитьПодключаемоеОборудование(ЭтотОбъект); НастроитьФормуПоДополнительнымПравам(); УстановитьВидимостьСтатусыСерийИПодарочныхСертификатов(); ОбщегоНазначенияРТКлиентСервер.УстановитьКартинкуДляКомментария(Элементы.СтраницаКомментарий, Объект.Комментарий); КонецПроцедуры
&НаСервере Процедура ПриЗаписиНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи) ор_ОбщегоНазначенияСервер.ПодписатьДокумент(ТекущийОбъект, ЭтотОбъект.ЭЦП_ПользовательКарты, Отказ); КонецПроцедуры

#Область ОбработчикиСобытийЭлементовТабличнойЧастиТовары

&НаКлиенте
Процедура ТоварыПередНачаломИзменения(Элемент, Отказ)

Если Элемент.ТекущийЭлемент = Элементы.ТоварыКоличествоУпаковок Тогда
ТекущиеДанные = Элементы.Товары.ТекущиеДанные;

Если НЕ ТекущиеДанные = Неопределено И (ТекущиеДанные.ИспользоватьСерийныеНомера ИЛИ НЕ ТекущиеДанные.СтатусУказанияСерий = 0) Тогда
Отказ = Истина;
Если ТекущиеДанные.ИспользоватьСерийныеНомера Тогда
ВвестиПодарочныеСертификаты();
Иначе
УказатьСерии(«КоличествоУпаковок»);
КонецЕсли;
КонецЕсли;

ИначеЕсли Элемент.ТекущийЭлемент = Элементы.ТоварыУпаковка
ИЛИ Элемент.ТекущийЭлемент = Элементы.ТоварыНоменклатураЕдиницаИзмерения Тогда

Если НЕ ТекущиеДанные = Неопределено И НЕ ТекущиеДанные.СтатусУказанияСерий = 0 Тогда
Отказ = Истина;
УказатьСерии(«Упаковка»);
КонецЕсли;
КонецЕсли;

&НаКлиенте
Процедура ТоварыНоменклатураПриИзменении(Элемент)

СтруктураДействий = Новый Структура;
СтруктураДействий.Вставить(«ЗаполнитьТипНоменклатуры»);
СтруктураДействий.Вставить(«ПроверитьСерийныеНомераПоВладельцу»,
ОбработкаТабличнойЧастиТоварыКлиент.ПолучитьСтруктуруПроверкиСерийныхНомеровПоВладельцу(ТекущаяСтрока, Объект.СерийныеНомера));
СтруктураДействий.Вставить(«ПроверитьХарактеристикуПоВладельцу», ТекущаяСтрока.Характеристика);
СтруктураДействий.Вставить(«ПроверитьЗаполнитьУпаковкуПоВладельцу» , ТекущаяСтрока.Упаковка);
СтруктураДействий.Вставить(«ПересчитатьКоличествоЕдиниц»);
СтруктураДействий.Вставить(«ЗаполнитьЦенуПродажи», СтруктураЗаполненияЦеныКлиент());
СтруктураДействий.Вставить(«ПересчитатьСумму»);

СтруктураСправки = Новый Структура;
СтруктураСправки.Вставить(«Дата», Объект.Дата);
СтруктураДействий.Вставить(«ПроверитьНеобходимостьВводаСправкиНаАлкоголь», СтруктураСправки);

ОбработкаТабличнойЧастиТоварыКлиент.ПриИзмененииРеквизитовВТЧКлиент(Объект.Товары, ТекущаяСтрока, СтруктураДействий, КэшированныеЗначения);

Если ОбработкаТабличнойЧастиТоварыКлиент.НеобходимоОбновитьСтатусыСерий(
Элементы.Товары, КэшированныеЗначения, ПараметрыУказанияСерий) Тогда

ЗаполнитьСтатусыУказанияСерийПриОкончанииРедактированияСтрок ­иТЧ(ТекущаяСтрокаИдентификатор, КэшированныеЗначения);
ОбработкаТабличнойЧастиТоварыКлиент.ОбновитьКэшированныеЗначенияДляУчетаСерий(Элементы.Товары, КэшированныеЗначения,ПараметрыУказанияСерий);

Если Не ЕстьАлкогольнаяПродукцияЕГАИС И ТекущаяСтрока.НеобходимостьВводаСправкиНаАлкоголь Тогда
ЕстьАлкогольнаяПродукцияЕГАИС = Истина;
УстановитьВидимостьИДоступностьЕГАИС();
КонецЕсли;

&НаКлиенте
Процедура ТоварыХарактеристикаПриИзменении(Элемент)

СтруктураДействий = Новый Структура;
СтруктураДействий.Вставить(«ЗаполнитьЦенуПродажи» , СтруктураЗаполненияЦеныКлиент());
СтруктураДействий.Вставить(«ПересчитатьСумму»);

ОбработкаТабличнойЧастиТоварыКлиент.ПриИзмененииРеквизитовВТЧКлиент(Объект.Товары, ТекущаяСтрока, СтруктураДействий, КэшированныеЗначения);

&НаКлиенте
Процедура ТоварыХарактеристикаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)

ОбработкаТабличнойЧастиТоварыКлиент.ВыбратьХарактеристикуНоменклатуры(ЭтотОбъект, Элемент, СтандартнаяОбработка, Элементы.Товары.ТекущиеДанные);

&НаКлиенте
Процедура ТоварыУпаковкаПриИзменении(Элемент)

СтруктураДействий = Новый Структура;
СтруктураДействий.Вставить(«ПересчитатьКоличествоЕдиниц»);
Если ТекущаяСтрока.Количество > 0 Тогда
СтруктураДействий.Вставить(«ПересчитатьЦенуЗаУпаковку», ТекущаяСтрока.Количество);
Иначе
СтруктураДействий.Вставить(«ЗаполнитьЦенуПродажи» , СтруктураЗаполненияЦеныКлиент());
КонецЕсли;

ОбработкаТабличнойЧастиТоварыКлиент.ПриИзмененииРеквизитовВТЧКлиент(Объект.Товары, ТекущаяСтрока, СтруктураДействий, КэшированныеЗначения);

&НаКлиенте
Процедура ТоварыУпаковкаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)

ОбработкаТабличнойЧастиТоварыКлиент.ВыбратьУпаковкуНоменклатуры(ДанныеВыбора, СтандартнаяОбработка, Элементы.Товары.ТекущиеДанные);

&НаКлиенте
Процедура ТоварыКоличествоУпаковокПриИзменении(Элемент)

&НаКлиенте
Процедура ТоварыЦенаПриИзменении(Элемент)

СтруктураДействий = Новый Структура;
СтруктураДействий.Вставить(«ПересчитатьСумму»);

ОбработкаТабличнойЧастиТоварыКлиент.ПриИзмененииРеквизитовВТЧКлиент(Объект.Товары, ТекущаяСтрока, СтруктураДействий, КэшированныеЗначения);

&НаКлиенте
Процедура ТоварыСуммаПриИзменении(Элемент)

СтруктураДействий = Новый Структура;
СтруктураДействий.Вставить(«ПересчитатьЦенуПоСуммеВЗакупках»);

ОбработкаТабличнойЧастиТоварыКлиент.ПриИзмененииРеквизитовВТЧКлиент(Объект.Товары, ТекущаяСтрока, СтруктураДействий, КэшированныеЗначения);

&НаКлиенте
Процедура ТоварыПередУдалением(Элемент, Отказ)

&НаКлиенте
Процедура ТоварыПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)

Если Копирование Тогда

ТекущаяСтрока = Элементы.Товары.ТекущиеДанные;
ТекущаяСтрока.КлючСвязиСерийныхНомеров = 0;

Если ТекущаяСтрока.ИспользоватьСерийныеНомера Тогда
ТекущаяСтрока.КоличествоУпаковок = 0;
ТекущаяСтрока.Количество = 0;
КонецЕсли;

ОбработкаТабличнойЧастиТоварыКлиент.ОбновитьКэшированныеЗначенияДляУчетаСерий(
Элемент,КэшированныеЗначения,ПараметрыУказанияСерий, Копирование);

&НаКлиенте
Процедура ТоварыПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)

Если ОбработкаТабличнойЧастиТоварыКлиент.НеобходимоОбновитьСтатусыСерий(
Элемент,КэшированныеЗначения,ПараметрыУказанияСерий) Тогда

ЗаполнитьСтатусыУказанияСерийПриОкончанииРедактированияСтрок ­иТЧ(ТекущаяСтрокаИдентификатор, КэшированныеЗначения);
ОбработкаТабличнойЧастиТоварыКлиент.ОбновитьКэшированныеЗначенияДляУчетаСерий(Элемент,КэшированныеЗначения,ПараметрыУказанияСерий);

Если НоваяСтрока Тогда
ПроверитьВыводНапоминанияЕГАИС();
КонецЕсли;

&НаКлиенте
Процедура ТоварыПослеУдаления(Элемент)

Если ОбработкаТабличнойЧастиТоварыКлиент.НеобходимоОбновитьСтатусыСерий(
Элемент,КэшированныеЗначения,ПараметрыУказанияСерий,Истина) Тогда

ЗаполнитьСтатусыУказанияСерийПриОкончанииРедактированияСтрок ­иТЧ(Неопределено, КэшированныеЗначения);
ОбработкаТабличнойЧастиТоварыКлиент.ОбновитьКэшированныеЗначенияДляУчетаСерий(
Элемент,КэшированныеЗначения,ПараметрыУказанияСерий);

Если ЕстьАлкогольнаяПродукцияЕГАИС Тогда
ЕстьАлкогольнаяПродукцияЕГАИС = Ложь;
Для Каждого СтрокаТовары Из Объект.Товары Цикл
Если СтрокаТовары.НеобходимостьВводаСправкиНаАлкоголь Тогда
ЕстьАлкогольнаяПродукцияЕГАИС = Истина;
Прервать;
КонецЕсли;
КонецЦикла;
УстановитьВидимостьИДоступностьЕГАИС();
КонецЕсли;

&НаКлиенте
Процедура ТоварыПриАктивизацииЯчейки(Элемент)

Если РедактированиеТЧТовары Тогда
Если Элемент.ТекущийЭлемент = Элементы.ТоварыКоличествоУпаковок Тогда
ТекущиеДанные = Элементы.Товары.ТекущиеДанные;
Если НЕ ТекущиеДанные = Неопределено И (ТекущиеДанные.ИспользоватьСерийныеНомера ИЛИ НЕ ТекущиеДанные.СтатусУказанияСерий = 0) Тогда
Элементы.Товары.ЗакончитьРедактированиеСтроки(Ложь);
Если ТекущиеДанные.ИспользоватьСерийныеНомера Тогда
ВвестиПодарочныеСертификаты();
Иначе
УказатьСерии(«КоличествоУпаковок»);
КонецЕсли;
КонецЕсли;

ИначеЕсли Элемент.ТекущийЭлемент = Элементы.ТоварыУпаковка
ИЛИ Элемент.ТекущийЭлемент = Элементы.ТоварыНоменклатураЕдиницаИзмерения Тогда

Если НЕ ТекущиеДанные = Неопределено И НЕ ТекущиеДанные.СтатусУказанияСерий = 0 Тогда
Элементы.Товары.ЗакончитьРедактированиеСтроки(Ложь);
УказатьСерии(«Упаковка»);
КонецЕсли;
КонецЕсли;

Работа со справочником Статьи затрат в 1С Бухгалтерия Предприятия 8

При формировании документов «Требование-накладная», «Отчет комиссионера», «Перемещение товара» и т.п. в 1С Бухгалтерия 3.0 часто возникает вопрос: каким образом настроить автоматическое заполнение поля «статья затрат» в табличной части документа? Для этого в разделе «Справочники» есть отдельный справочник Статьи затрат в 1С Бухгалтерия, при заполнении которого возможно указать:
1. наименование Статьи затрат в 1С Бухгалтерия – какое наименование статьи затрат будет введено в данное поле, такое и будет отображено в документах использования данной статьи;
2. группу статей – при работе с данным справочником возможно создавать папки (группы), в которых будут храниться данные статьи затрат, соответственно, при создании новой статьи затрат в справочнике будет возможность выбрать группу из списка;
3. вид расхода в 1С – в данном поле необходимо выбрать вид расхода для целей налогового учета, например: материальные расходы, оплата труда и т.д.;
4. использование по умолчанию – в этом поле в 1С Бухгалтерия Предприятия 3.0 необходимо выбрать документ, в котором и будет использоваться данная статья, т.е. после того, как запишем данный элемент в справочник, при создании выбранного документа будет автоматически заполняться поле «Статья затрат».

Создание статьи затрат в 1С Бухгалтерия 1

2. На что стоит обратить внимание при работе с справочником статей затрат

Описанным выше образом можно создать статью затрат для любого вида расхода. Обратите внимание, что автоматическое заполнение статьи затрат происходит только в тех документах, для которых предусмотрена данная настройка, т.е. если нет возможности выбрать какой-либо документ в поле «Использование по умолчанию», то в этом документе не будет автоматически проставлена созданная статья затрат.
Вот мы и разобрались в том, как в 1С БП работать со справочником «Статьи затрат». Конечно, в работе с 1С есть еще много неочевидных нюансов, так что если у Вас возникнут вопросы, смело пишите нам. Мы с удовольствием поможем разобраться во всех сложностях программ 1С!
Специалист компании ООО «Кодерлайн» Шачнева Елена

Вас могут заинтересовать следующие статьи:

94 [PROP_CODE] => TAGS2 [TITLE] => Вас могут заинтересовать следующие семинары: ) —> 95 [PROP_CODE] => TAGS [TITLE] => Вас могут заинтересовать следующие вебинары: ) —> Как сделать в 1С [1] => 1С: Конвертация данных [2] => Конвертация данных [3] => Обмен между базами [4] => Закрытие месяца [5] => Оценка задач [6] => Отчеты в 1С [7] => Моделирование [8] => HTTP [9] => Управление проектами [10] => БУ [11] => com-объекты [12] => 1С: WMS Управление складом [13] => РСБУ [14] => 1С: Сценарное тестирование [15] => Запросы 1С [16] => LINUX [17] => WEB [18] => Оптимизация [19] => 1С:Зарплата и Управление Персоналом [20] => Excel [21] => 1С: ERP [22] => ADO [23] => 1С:Управление производственным предприятием [24] => Внедрение [25] => Продажи [26] => Отчетность [27] => 1С: Розница [28] => 1С: CRM [29] => 1С:Бухгалтерия [30] => 1С:Комплексная автоматизация [31] => Производство [32] => Интеграция 1С [33] => Налоги [34] => Отпуск [35] => MS SQL Server [36] => Расширение конфигурации [37] => МСФО [38] => СКД [39] => Word [40] => WEB-сервисы 1С [41] => Внедрение ERP [42] => Перенос данных [43] => Торговое оборудование [44] => Лизинг [45] => 1С:Управление нашей фирмой [46] => Администрирование 1С [47] => 1С: Колледж [48] => Правила обмена [49] => 1С: Платформа ) —>

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *