Как в экселе сложить буквы
Перейти к содержимому

Как в экселе сложить буквы

  • автор:

Как в экселе сложить буквы

Все формулы массива (вводятся Ctrl+Shift+Enter).
Сумма всех цифр (суммирует только однозначные числа!), немного преобразованная формула ZORRO2005:
=СУММ((ДЛСТР(B4:J4)-ДЛСТР(ПОДСТАВИТЬ(B4:J4;СТРОКА(1:9);»»)))*СТРОКА(1:9))

Сумма всех цифр (однозначных чисел) в ячейках с буквой «н»:
=СУММ(ЕСЛИ(ЕЧИСЛО(ПОИСК(«н»;B4:J4));(ДЛСТР(B4:J4)-ДЛСТР(ПОДСТАВИТЬ(B4:J4;СТРОКА(1:9);»»)))*СТРОКА(1:9)))

Сумма цифр (однозначных чисел) до знака «/» в ячейках с буквой «н»:
=СУММ(ЕСЛИ(ЕЧИСЛО(ПОИСК(«н»;B4:J4));(ПОИСК(«/»;B4:J4&»/»)-1-ДЛСТР(ПОДСТАВИТЬ(ПСТР(B4:J4;1;ПОИСК(«/»;B4:J4&»/»)-1);СТРОКА(1:9);»»)))*СТРОКА(1:9)))

Пользователь
Сообщений: 47199 Регистрация: 15.09.2012
07.07.2011 08:54:26

Непонятка. У DV определение суммы чисел, стоящих перед «н», у меня — в ячейках с «н» перед знаком «/». По задаче непонятно, что хотел автор. Также неясно, могут ли быть 2-(3-)значные числа.

Пользователь
Сообщений: 628 Регистрация: 22.12.2012
07.07.2011 09:13:12

Непонятка. У DV определение суммы чисел, стоящих перед «н», у меня — в ячейках с «н» перед знаком «/». По задаче непонятно, что хотел автор. Также неясно, могут ли быть 2-(3-)значные числа.
Насколько я понял, тут есть попытка подсчета ночных часов и всех часов. Делал исходя из этого. Т.е. ночные точно не могут быть больше 9, а без «н» могут.

Сообщений: 60996 Регистрация: 14.09.2012
Контакты см. в профиле
07.07.2011 14:35:58

>> Т.е. ночные точно не могут быть больше 9
У меня на работе ночные с 22:00 до 06:00. Стало быть 8 часов.

Пользователь
Сообщений: 8196 Регистрация: 21.12.2012
07.07.2011 17:32:40

>> Т.е. ночные точно не могут быть больше 9
У меня на работе ночные с 22:00 до 06:00. Стало быть 8 часов.

А где час на обед? В профсоюз нужно обратиться..

Excel. Как сложить ячейки в excel , если в ячейках забита буква а не цифра ?

После двух часового раздумья по данному вопросу появилась желание предложить организаторам проекта «Вопросы и ответы» усовершенствовать систему начисления баллов.
Только за прочтения таких вопросов начислять баллы, а за ответ баллы умножать на коэффициент.
И так. Ячейки, содержащие значения, можно считать, как показал Randy Orton
Суммировать же буквы нельзя. Буквы можно СЦЕПИТЬ. Типа А и В сидели на трубе.
В ячейке А1 буква А, в ячейке В1 буква В
Формулы
=A1&B1 ( точно как в считалке)
=СЦЕПИТЬ (A1;B1)

Остальные ответы

Вот: =СЧЁТЗ (A1:A3) В скобках диапазон укажи.

Как в excel суммировать ячейки с цифрой и текстом?

5cab22ed2f557505831457.png

пример на скрине

  • Вопрос задан более трёх лет назад
  • 10583 просмотра

8 комментариев

Простой 8 комментариев

AnnTHony

формула или макрос?
maratmd @maratmd Автор вопроса
Saboteur @saboteur_kiev

IMHO формула не умеет считать цифры с буквами. Вам нужно хранить буквы и цифры в разных ячейках для формулы.

maratmd @maratmd Автор вопроса

5cab2c72b0219652214779.png

Saboteur, а если подсчитать сумму только тех ячеек где есть любая буква. Если просто использовать сумм, то суммируются ячейки без текста, а как сделать наоборот, чтобы суммировались только ячейки которые содержат любую букву?

Saboteur @saboteur_kiev
Число и строка — разные типы переменных. Формула не сможет суммировать.
maratmd @maratmd Автор вопроса

obezh

Что мешает сделать так:
Л П None
8 2
3 9
6
2
И потом уже суммировать цифры в столбцах
maratmd @maratmd Автор вопроса
Олег Беж, к сожалению не вариант
Решения вопроса 1

Volounteer

Bcoon @Volounteer

Для буквы «л» формула такая:
=СУММ(ЕСЛИОШИБКА(ЕСЛИ(ПОИСК(«л»;B4:G4);—ПОДСТАВИТЬ(B4:G4;»л»;»»));0))
Для «п» соответственно такая:
=СУММ(ЕСЛИОШИБКА(ЕСЛИ(ПОИСК(«п»;B4:G4);—ПОДСТАВИТЬ(B4:G4;»п»;»»));0))

Обе — формулы массива. Вводятся одновременным нажатием клавиш Ctrl+Shift+Enter

Ответ написан более трёх лет назад
Нравится 4 3 комментария
maratmd @maratmd Автор вопроса
Отдуши, вообще супер, то что нужно. Большое спасибо.
maratmd @maratmd Автор вопроса

Игорь, может еще поможете с одним вопросом, правда не знаю возможно ли вообще такое.

Суть в следующем. Для каждой ячейки хочу сделать выпадающий список с этими же значениями, например 8л;2п;3л и т.д

Как сделать чтобы в ячейке при выборе значения была видна только цифра? например я выбрал 8л из выпадающего списка, но в ячейке было видно только цифру 8, но при этом работала ваша формула

Для буквы «л» формула такая:
=СУММ(ЕСЛИОШИБКА(ЕСЛИ(ПОИСК(«л»;B4:G4);—ПОДСТАВИТЬ(B4:G4;»л»;»»));0))
Для «п» соответственно такая:
=СУММ(ЕСЛИОШИБКА(ЕСЛИ(ПОИСК(«п»;B4:G4);—ПОДСТАВИТЬ(B4:G4;»п»;»»));0))

Надеюсь понятно написал, что я хочу?

Volounteer

Bcoon @Volounteer

maratmd, думаю, тут не обойтись без макроса, который будет красить букву в цвет фона ячейки при выборе какого-то значения из списка. Таким образом, в списке будут цифры с буквами, а в ячейке видны только цифры (буквы будут окрашены в фоновый цвет). Других путей не вижу. Макрос надо поместить в модуль листа, диапазон замените на свой, в котором расположены ячейки со списками:

Private Sub Worksheet_Change(ByVal Target As Range) Dim n As Integer If Not Intersect(Target, Range("D1:D20")) Is Nothing Then For n = 1 To Len(Target) If Not (IsNumeric(Mid(Target, n, 1))) Then Target.Characters(n, 1).Font.Color = Target.Interior.Color End If Next n End If End Sub

Способы добавления значений в электронную таблицу

Одним из быстрых и простых способов добавления значений в Excel является использование автосуммы. Просто выберите пустую ячейку непосредственно под столбцом данных. Затем на вкладке Формула щелкните Автосумма > Сумма. Excel будет автоматически определить диапазон для суммы. (Автосумма также может работать по горизонтали при выборе пустой ячейки справа от ячеек для суммирования.)

AutoSum создает формулу для вас, чтобы вам не нужно было вводить текст. Однако если вы предпочитаете вводить формулу самостоятельно, см. функцию СУММ.

Добавление на основе условий

  • Используйте функцию СУММЕСЛИ , если требуется суммировать значения с одним условием. Например, если необходимо сложить общий объем продаж определенного продукта.
  • Используйте функцию SUMIFS , если требуется суммировать значения с несколькими условиями. Например, может потребоваться сложить общий объем продаж определенного продукта в пределах определенного региона продаж.

Сложение или вычитание дат

Общие сведения о том, как добавлять или вычитать даты, см. в разделе Добавление или вычитание дат. Более сложные вычисления даты см. в разделе Функции даты и времени.

Сложение и вычитание значений времени

Общие сведения о том, как добавлять или вычитать время, см. в статье Добавление или вычитание времени. Другие вычисления времени см. в разделе Функции даты и времени.

Дополнительные сведения

Вы всегда можете задать вопрос эксперту в Excel Tech Community или получить поддержку в сообществах.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *