Почему курсор перескакивает в начало строки
Перейти к содержимому

Почему курсор перескакивает в начало строки

  • автор:

3 способа устранить перескакивание курсора при наборе текста на ноутбуке

При наборе текста на ноутбуке некоторые пользователи сталкиваются с перескакиванием курсора в другое место документа, в результате чего ввод текста осуществляется уже в другом, случайном месте. Из-за этого приходится перепечатывать, исправлять и много ругаться. Такая проблема вызвана тем, что при наборе пальцы случайно касаются тачпада, что вызывает перемещение курсора в случайное место текста. Избавиться от такой проблемы достаточно просто — есть сразу несколько способов. Каждый из них можно использовать в зависимости от того, как именно вы пользуетесь ноутбуком. Но обо всем по порядку.

1. Отключение касаний

Именно касание (аналог нажатия на левую кнопку мышки) и вызывает перемещение курсора при наборе текста. Если отключить его и использовать кнопки (или нажатие на тачпад, если он представляет собой одну большую кнопку), то проблема решится сама собой. Это может вызвать определенные неудобства и, вероятно, потребуется какое-то время на привыкание. Но если вы часто печатаете и постоянно сталкиваетесь с проблемой перескакивающего курсора, то такое решение может сильно упростить жизнь.

Настройки мышки в Панели управления, вкладка Touchpad

Настройки тачпада, отключение касаний (удара)

Отключить касания можно в настройках мышки Панели управления. В зависимости от типа тачпада и установленного для него программного обеспечения названия пунктов и их расположения могут различаться.

2. Автоматическая блокировка тачпада на время набора текста

Программы блокировки тачпада:

Программа Touchpad Blocker блокирует тачпад во время печати

Несмотря на то, что многие тачпады сегодня оснащаются функцией блокировки при печати на уровне операционной системы или драйверов, задержки блокировки может быть недостаточно. При интенсивной печати все равно происходит перемещение курсора. Например, такая проблема имеется у меня на ноутбуке Samsung 530. Функция блокировки тачпада при печати имеется, но при интенсивной и быстрой печати все равно курсор летает по документу, что сильно раздражает. В этом случае можно воспользоваться сторонней утилитой, например, Touchpad Blocker. В настройках программы можно задать задержку, что позволит настроить ее под себя и с комфортом работать, не отключая никаких элементов. Помимо этого, в программе можно отслеживать количество блокировок, установить звуковой сигнал на блокировку и многое другое.

3. Полное отключение тачпада

Отключение тачпада при подключении внешней мышкиЕсли для работы на ноутбуке используется внешняя мышка, то тачпад можно полностью отключить, решив тем самым проблемы кардинально. В настройках системы есть опции, которые позволяют отключать тачпад при подключении внешней мышки. Это отличное решение, но работает не всегда корректно. Например, после перезагрузки или выхода компьютера из режима сна тачпад может снова заработать. И это несмотря на активную опцию отключения при подключении мышки. Полное отключение тачпадаЕсли отключение тачпада при подключении мышки ведет себя таким нехорошим образом, то можно полностью отключить тачпад. В этом случае при отключении мышки вы не сможете работать с ним, потребуется повторная активация, а также появятся все те проблемы, от которых мы стараемся избавиться. Именно потому это можно назвать самым радикальным способом избавления от проблемы, к которому лучше всего прибегать в самую последнюю очередь.

Заключение

Проблему перескакивающего курсора при печати на ноутбуке можно решить несколькими способами. Для себя я выбрал отключение касаний. Это привело к тому, что мне пришлось привыкнуть к использованию кнопок тачпада (в те моменты, когда я им пользуюсь). Это не так удобно, как простое касание в любом месте. При подключении же внешней мышки тачпад автоматически блокируется, так что я даже не могу им управлять в этот момент. Когда мне надо воспользоваться ноутбуком в походных условиях, тачпад работает, так как мышка не используется. Но и курсор не перескакивает, так как отключены касания.

Понравилась статья? Поделитесь!

  1. Как отключить веб-камеру и микрофон на ноутбуке Windows 10
  2. Touchpad Blocker — маленький помощник пользователя ноутбука
  3. Как правильно диагностировать и устранить проблемы с интернетом в Windows
  4. Почему не нужно очищать Корзину Windows
  5. Что такое пиратский софт и почему надо прекратить его использовать

Перескакивает курсор в начало строки, в строке поиска динамического списка

Есть самописная конфигурация по учету товаров в рознице. Для справочника товаров через дополнение формы добавлена строка поиска динамического списка. Проблема в следующем: иногда при поиске(наборе текста), после нескольких введенных символов, курсор уходит в начало строки. Например, пользователь хочет найти «товар1», после ввода «тов» курсор переходит в начало строки, а пользователь не видя этого продолжает печатать и получается в итоге «ар1тов». Случается такое не всегда. При попытках увидеть эту проблему воочию, случилось 1 раз за час. Тестирование и исправление не помогает, удаление и восстановление индексов поиска тоже. База используется в файловом режиме. Программ типа punto switcher не установлено. Пока думается, что виноват код конфигурации. Только непонятно, что именно не так. Нужна помощь по решению этой проблемы.

Версия приложения: от 8.3.8.1652 до 8.3.8.2027

По конфигурации:
используется внешний вид «такси» и «8.2»
В справочнике товаров есть событие «ПриАктивизацииСтроки» в котором следующий код.

ТекДан = Элементы.Список.ТекущиеДанные; Если ТекДан <> Неопределено Тогда Если Строка(ТекДан.Штрихкод)<>СтарыеТекДан Тогда //Количество в упаковках Делимость = ТекДан.Делимость; КО = ТекДан.КоличествоОстаток; Цена = ТекДан.Цена; Если ДелимостьНеопределено Тогда Для каждого стрС Из ДанСк Цикл СтрокаСкидки = Скидки.Добавить(); СтрСтрукт = стрС.Значение; СтрокаСкидки.Количество = СтрСтрукт.Количество; СтрокаСкидки.Процент =СтрСтрукт.Процент; СтрокаСкидки.Скидка =СтрСтрукт.Скидка; Если СтрСтрукт.Скидка= "Централизованная" Тогда ВключитьКнопкуПечатиЦенникаСоскидкой=Истина; КонецЕсли; СтрокаСкидки.СоСкидкойУп =СтрСтрукт.СоСкидкойУп; СтрокаСкидки.СоСкидкойШт =СтрСтрукт.СоСкидкойШт; СтрокаСкидки.Приоритет =СтрСтрукт.Приоритет; КонецЦикла; КонецЕсли; СтарыеТекДан = ТекДан.Штрихкод; Если ВключитьКнопкуПечатиЦенникаСоскидкой Тогда Элементы.ФормаПечатьЦенникаДляТекущегоТовараСоСкидкой.Видимость=Истина; Иначе Элементы.ФормаПечатьЦенникаДляТекущегоТовараСоСкидкой.Видимость=Ложь; КонецЕсли; КонецЕсли; КонецЕсли;

Также есть обработчик ожидания в модуле управляемого приложения, запускается раз в 5 сек.
Код обработчика ожидания:

// Проверка Завершения приложения ПроверкаВыходаИзСистемы = Общий.ПроверкаВыходаИзСистемы(); Если ТипЗнч(ПроверкаВыходаИзСистемы)=Тип("Структура") Тогда Если ПроверкаВыходаИзСистемы.ЗавершениеРаботы Тогда ЗавершитьРаботуСистемы(Ложь); ИначеЕсли ПроверкаВыходаИзСистемы.ОткрытьФорму Тогда ОткрытьФорму("ОбщаяФорма.ФормаВыходаИзСистемы". РежимОткрытияОкнаФормы.БлокироватьВесьИнтерфейс); КонецЕсли; КонецЕсли; //Запуск регламентированных заданий Если Общий.РольДоступнаНаСервере("Заведующий") Тогда //Завершение работы Заведующих Между 5:00 И 5:15 Если (Число(Формат(ТекущаяДата(), "ДФ=ЧЧмм"))>600) И (Число(Формат(ТекущаяДата(), "ДФ=ЧЧмм"))<615) Тогда ЗавершитьРаботуСистемы(); КонецЕсли; //Показать новые загруженные утвержденные товары заведующим Если ПоказыватьНовыеУтвержденныеТовары И Общий.ЕстьНовыеУтвержденныеТовары() Тогда ОткрытьФорму("РегистрСведений.УтвержденныеТовары.Форма.ФормаСпискаНовыхУтвержденныхТоваров", . РежимОткрытияОкнаФормы.БлокироватьВесьИнтерфейс); КонецЕсли; //Вывод информации о разногласии цен //Запускать раз в час Если (глВремяПоследнегоПоказаИнформацииОРазногласииЦен =Неопределено) ИЛИ (глВремяПоследнегоПоказаИнформацииОРазногласииЦен<(ТекущаяДата()-(60*60))) Тогда Если ПоказыватьИнформациюОРазногласииЦен Тогда глВремяПоследнегоПоказаИнформацииОРазногласииЦен = ТекущаяДата(); ОткрытьФорму("Документ.АктРазногласияЦен.Форма.ФормаТоваровСРазногласиемЦен"); КонецЕсли; КонецЕсли; //Централизованная переоценка, Загрузка и вывод информации о переоцененных товарах Если ЗапускатьЦентрализованнуюПереоценку Тогда ОбменСервер.ЗагрузкаЦентрализованнойПереоценкиВФоне(); Если Общий.ПолучитьКонстанту("ПоказатьИнформациюОЦентрализованнойПереоценке") Тогда ОткрытьФорму("РегистрСведений.ТоварыОбработанныеЦентрализованнойПереоценкой.Форма. ФормаИнформацииОТоварахОбработанныхЦентрПереоценкой", . ВариантОткрытияОкна.ОтдельноеОкно. РежимОткрытияОкнаФормы.БлокироватьВесьИнтерфейс); Общий.УстановитьКонстанту("ПоказатьИнформациюОЦентрализованнойПереоценке",Ложь); КонецЕсли; Если ((Общий.ПараметрыСеанса("ДатаИнфОТоварахПереоценки")+(60*30))<ТекущаяДата()) И Общий.ЕстьТоварыТоварыОбработанныеЦентрализованнойПереоценкой() Тогда ОткрытьФорму("РегистрСведений.ТоварыОбработанныеЦентрализованнойПереоценкой.Форма. ФормаИнформацииОТоварахОбработанныхЦентрПереоценкой", . РежимОткрытияОкнаФормы.БлокироватьВесьИнтерфейс); Общий.ПараметрыСеанса("ДатаИнфОТоварахПереоценки",Ложь,ТекущаяДата()); КонецЕсли; КонецЕсли; //Запуск регламентных заданий Если НЕ ЗапускатьВыполнениеРегламентныхЗаданийВОдномПроцессе Тогда ВыполнитьОбработкуЗаданий(); КонецЕсли; КонецЕсли; Если ЗапускатьВыполнениеРегламентныхЗаданийВОдномПроцессе и ВыполнятьРегламентныеЗадания Тогда ВыполнитьОбработкуЗаданий(); КонецЕсли; Если ТекущийПользовательРобот Тогда Робот2.ОтветНаЗапросыИзвне(); КонецЕсли; //Завершение работы после 22:00 Если (Число(Формат(ТекущаяДата(), "ДФ=ЧЧ"))>22) И (НЕ ВыполнятьРегламентныеЗадания) И ЗапускатьВыполнениеРегламентныхЗаданийВОдномПроцессе И (Не Общий.РольДоступнаНаСервере("ПолныеПрава")) Тогда ЗавершитьРаботуСистемы(); КонецЕсли;

Также выполняются регламентные задания, для запуска регламентных заданий используется отдельный процесс.

p.s. На просторах интернета такой проблемы не нашел.

Почему курсор перескакивает в начало строки

Многие проблемы быстрее решаются поиском по форуму и чтением FAQ, чем созданием новой темы и томительным ожиданием ответа.

Страницы: 1

№1 19-05-2015 10:13:29

Firefox

samura Участник Группа: Members Зарегистрирован: 17-09-2010 Сообщений: 13 UA: 38.0 Веб-сайт

Перескакивание курсора

Здравствуйте. При наборе текста в поисковике браузера курсор частенько перескакивает в адресную строку. Думал случайность, но это повторяется с завидным постоянством. Страшно бесит. Решил погуглить — такая проблема есть.

зы: может так подленько приучают вводить поисковые запросы в адресную строку?

Перескакивает курсор в input при добавлении текста

Всем добрый день, хочу сделать живой поиск как у Яндекса, все уже почти получилось, но если «переходить» клавишами клавиатуры вверх и вниз по списку предложенных вариантов поиска, то курсор в input переходит то в конец текста, то в начало. Соответственно если нажимать клавишу вниз, то курсор встает в конец текста в поле input, если нажать клавишу вверх, то курсор встанет сначала в начало текста в поле input , а только при повторном нажатии будет «переходить» по списку. Переходить в кавычках потому как просто имитируется выбор словосочетания в списке путем выделения цвета. Если убрать код вставки выбранного текста в поле input , то все нормально, курсор стоит на прежнем месте. $(‘#search’).val($(«li:eq(«+poz+»)»).text()); Вот часть кода для «перемещения» по списку вариантов словосочетания:

$('#search').keydown(function(e)< $("ul#resSearch").children().each(function() < $(this).css( "color", "black" ); >); razmer=$("ul#resSearch li").length; if (poz==-1) else if (poz==razmer) if (e.keyCode == '40') < $('ul#resSearch').find("li:eq("+poz+")").css( "color", "red" ); $('#search').val($("li:eq("+poz+")").text()); poz++;>if (e.keyCode == '38') < poz--; $('ul#resSearch').find("li:eq("+poz+")").css( "color", "red" ); $('#search').val($("li:eq("+poz+")").text()); >>); 

Отслеживать

22.4k 11 11 золотых знаков 56 56 серебряных знаков 121 121 бронзовый знак

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *